ISPConfig Maildir email filenames are enclosed in single quotes

Discussion in 'Server Operation' started by jnewman67, Mar 24, 2021.

  1. jnewman67

    jnewman67 New Member

    CentOS 8 Stream (fully updated), ISPConfig 3.2.3 server (used the CentOS 8 ISPConfig Perfect Server method..)

    i come from an older version of RHEL, so maybe something has changed that i'm not aware of...

    I was poking around in the Maildir folders (cur/new/tmp) under /var/vmail and noticed that the actual email files are have single quotes wrapped around their names when I do an "ls -l" within the directory. an "ls" shows the same thing.

    going back to my home directory, same thing, but only on files that have spaces in them. i assume it's the non-alphnum characters that are causing the issue. i unaliased LS just in case there was some forced setting there causing it, but still the same thing.

    when i start typing in one of these names without the single quote, and press the TAB key to autocomplete the name, it finds it and escapes the non-alphanum characters, but no single quotes.

    Can someone shed some light on this behavior? obviously, it's intentional, and probably useful, but this must be a newer feature - i didn't notice it in CentOS 7, though I didn't play around in there long before switching to 8 instead.

    Curious, thanks.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    It is simply the (new?) behavior of /bin/ls, use -N to disable it.
     

Share This Page