ISPConfig Mail wih Roundcube

Discussion in 'Installation/Configuration' started by kendel, Jan 12, 2013.

  1. kendel

    kendel New Member

    Checking the ispconfig mail config location: /usr/local/ispconfig/interface/web/mail/webmailer.php

    Contains:
    isset($_SERVER['HTTPS'])? $http = 'https' : $http = 'http';
    header('Location:' . $http . '://' . $serverData['server_name'] . '/roundcube' );

    I simple changed the link to roundcube but instead of the login page I get:
    Index of /roundcube
    [ICO] Name Last modified Size Description
    [DIR] Parent Directory -
    Apache/2.2.22 (Ubuntu) Server at mail.example.com Port 80

    How can fix this? I verified it works externally with another virtual host separate server alias. Can I simple change the header to the external mail link... Or how can I make the insternal not show Index of /roundcube?
     
  2. kendel

    kendel New Member

    Does anyone have any ideas of the best way to change the internal link so it works?

    Does the mail server need quota? (I ask because none of the guides covered it but, within ISPConfig it maintains a quota for mail users.
    Also I noticed alot of error under the Monitor tab, Log Files section:

    Show Mail Queue:
    Code:
    Data from: 2013-01-18 14:35
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    528C610042F 4347 Wed Jan 16 06:53:41 MAILER-DAEMON
    (temporary failure)
    [email protected]
    
    61AF2100EB4 3275 Wed Jan 16 06:53:41 MAILER-DAEMON
    (temporary failure)
    [email protected]
    
    6C2531000A1 3399 Wed Jan 16 06:53:41 MAILER-DAEMON
    (temporary failure)
    [email protected]
    
    -- 11 Kbytes in 3 Requests.
    
    Show Mail Warn-log (I don't recall any of the guides I followed covering any of these topics)
    Code:
    Unable to read /var/log/mail.warn
    
    Show Mail Error-Log (Long list regarding permissiong)
    Code:
    Jan 17 23:53:56 mail dovecot: lda(root): Error: chdir(/root/) failed: Permission denied (euid=65534(nobody) egid=65534(nogroup) missing +x perm: /root, dir owned by 0:0 mode=0700)
    Jan 17 23:53:56 mail dovecot: lda(root): Error: chdir(/root) failed: Permission denied
    Jan 17 23:53:56 mail dovecot: lda(root): Error: user root: Initialization failed: Initializing mail storage from mail_location setting failed: stat(/root/Maildir) failed: Permission denied (euid=65534(nobody) egid=65534(nogroup) missing +x perm: /root, dir owned by 0:0 mode=0700)
    
    Show System Message-log:
    Code:
    Unable to read /var/log/messages
    
    Show ISPC Crong-Log (this list seems to be a really long repeat of itself)
    Code:
    sh: repquota: command not found
    sh: repquota: command not found
    sh: repquota: command not found
    sh: repquota: command not found
    
     
    Last edited: Jan 18, 2013
  3. kendel

    kendel New Member

    Looking for solutions regarding these errors still.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The links to the webmail client are freely configurable under System > Interface config. You can enter any URL there. So all you have to do is to insert the URL to the location were you installed your webmail client there to get this a link location for the webmail icon in ispconfig.

    No. The mailserver deos not need quota.

    This file should exist out of the box on any Debian server, so it is not creaed by ispconfig.

    This is most likely a delivery attempt to the root user, e.g. a system message. Add a alias for root in /etc/aliases pointing to a real email address and then run command newaliases.

    Thats ok.
     

Share This Page