ISPConfig Mail Import: Funny Error

Discussion in 'Installation/Configuration' started by ZeroEnna, Jul 16, 2018.

  1. ZeroEnna

    ZeroEnna Member

    Hey guys,
    so I have a problem. I have an old system (Debian 8, ISPConfig 3.1.12) that needs to be run down. The Websites and so on are migrated manually, however, the Mail accounts need to be migrated via the ISPConfig Mail Import Tool unter "Tools".
    I created a remote account on the SOURCE System, and started the connection from the TARGET System. However, I get a funny looking error message:

    "Successfully connected to remote server. Could not connect to host"
    PHP Soap is installed and enabled on both systems. I also havbe not found a definitive solution for this problem yet. So....anyone?

    Thank you in advance.
    Kind Regards

    Zero
     
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    the first success is the soap connection, the second ... hmm a guess would be database server not reachable? dunno
    but can't you just copy the mail user table to the new system and copy the /var/vmail folder via rsync?
    If you migrated the user accounts, the system_ids and so on should be identical I think.
     
  3. ZeroEnna

    ZeroEnna Member

    Just a migration is not possible, since I want to add these mailaccounts to an existing server.
    Database? Will check on that. set root to % for now.
     
  4. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    I haven't looked at the code though, but I bet @till have a simple answer for some progress
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is probably the ssl cert on the old server. The import tool ignores the ssl cert on first test connect but later on it aceepts only valid ssl certs. I changed the code to support self-signed ssl certs on second connect now too. Update the new server to git-stable branch to get the update for the import tool.
     
    ztk.me likes this.
  6. ZeroEnna

    ZeroEnna Member

    Hello @till , I will updte these servers and test it, however, there are no self-signed certs. All Certs on both servers are LE certs, so they are pretty much valid.
     
  7. ZeroEnna

    ZeroEnna Member

    Hello @till , thank you very much! Updating to git-stable has solved the problem. I was able to import all the mailbox settings from the old server successfully!
     
  8. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    I know a company where u wait months for solving that or pay money big time, awesome :)

    and may I suggest moving the thread somewhere outside tips/tricks maybe?
     

Share This Page