ispconfig login error (mysql)

Discussion in 'Installation/Configuration' started by dtrotter, Aug 16, 2006.

  1. dtrotter

    dtrotter New Member

    Hey all! I recently installed ispConfig and it was working great until I had some mysql issues. I thought that I got things figured out until I tried logging in to ispconfig as admin (or anyone else as far as that goes). Here is the error that I receive:

    >>

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60

    <<

    I know it has to do with authentication between the mysql database and ispconfig, but I cant figure out how to resolve it.

    Thank in advance everyone!

    Thanks!

    Devin
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Plese check that the username and password for the mysql database in the file /home/admispconfig/ispconfig/lib/config.inc.php are correct for your mysql database. Then check with "netstat -tap" that your mysql database is listening on a tcp socket.
     
  3. dtrotter

    dtrotter New Member

    Ha! Go figure... I had already changed that to match the mysql password, but of course I had a typo. Thanks for getting me back on track! I reset it and restarted ispconfig and all is well now! Thanks a ton!

    Devin
     
  4. tommytomato

    tommytomato New Member

    I followed all the step in this tutorial
    http://www.howtoforge.com/perfect_setup_debian_sarge_strato
    and I cant seem to log into ISPconfig using admin admin. is there anyway to change it or reset it please.

    I did check the above Quote details and Its all ok

    TT :cool:
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If this is your first login, then the problem is not the admin password, the problem is that ISPConfig is not able to connect to your mysql database or the sys_user table does not exist.

    Please post the output of: netstat -tap

    Have you created the database for ispconfig manually or did you run the ispconfig setup script several times?
     
  6. tommytomato

    tommytomato New Member


    I re did this again, I'm having troubles with the https now
    I did create the database this time as where before I may of miss it

    any way to get it to load http instead of https

    [​IMG]


    TT
     
    Last edited: Aug 17, 2006
  7. dtrotter

    dtrotter New Member

  8. tommytomato

    tommytomato New Member

    what do they mean by enter pass phrase is like that a password ?

    TT
     
  9. tommytomato

    tommytomato New Member

    I'm going through it again
    here is my netstat -tap

    Code:
    members:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:imaps                 *:*                     LISTEN     1015/inetd
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     2428/mysqld
    tcp        0      0 *:pop3                  *:*                     LISTEN     1015/inetd
    tcp        0      0 *:imap2                 *:*                     LISTEN     1015/inetd
    tcp        0      0 *:sunrpc                *:*                     LISTEN     816/portmap
    tcp        0      0 *:auth                  *:*                     LISTEN     1015/inetd
    tcp        0      0 192.168.1.4:domain      *:*                     LISTEN     2107/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN     2107/named
    tcp        0      0 *:790                   *:*                     LISTEN     1032/rpc.statd
    tcp        0      0 *:ssh                   *:*                     LISTEN     1027/sshd
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     2107/named
    tcp        0      0 *:smtp                  *:*                     LISTEN     1009/exim4
    tcp        0    148 192.168.1.4:ssh         192.168.1.7:3208        ESTABLISHED1050/0
    tcp        0      0 192.168.1.4:ssh         192.168.1.7:3213        ESTABLISHED1956/sshd: [email protected]
    tcp        0      0 192.168.1.4:ssh         192.168.1.7:3212        ESTABLISHED1950/sshd: [email protected]
    members:~#
    
    TT
     
  10. tommytomato

    tommytomato New Member

    I got it going

    just have to learn how to use it now

    TT
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Did you install the database manually, or did the installer do it?
     
  12. tommytomato

    tommytomato New Member

    Yer I did it by hand

    db_ispconf I think it was, were do I find my email address to access webmail ?

    I thought it was the user I put in while I was setting up the OS

    TT
     
  13. falko

    falko Super Moderator ISPConfig Developer

  14. dtrotter

    dtrotter New Member

    Yes... Basically when you start ISPconfig, it will launch its secure apache and ask you for the passphrase to ensure that it should be loaded and that you have permissions.

    As far as your mysql goes, can you connect to your mysql server using the mysql client?

    Another thing that is sometimes easier is installing Webmin. It will allow you to use a web interface to configure everything running on your server including mysql. You can then make sure that your database is there, and reset the database password from the gui. Some people dont like it because it is an interface, but I am all about simplicity. :)


    Devin
     
  15. tommytomato

    tommytomato New Member

    I installed the server again, called it members and I use it as my sub ( members.rockinghamgateway.com )
    It now has ISPconfig installed as well and I think uebimiau is in there as well, however I cant log in to check mail, I also went with http instead of https, I can allwyas block out port 81 on my router or using smooth wall.

    as far as i know I have whats in the image installed
    any tips on how to access the uebimiau ?

    After I've built these server's they are all going into this
    http://forum.diywebserver.com/index.php?topic=4126.0

    also looking at build another box using ubuntu :D

    TT

    [​IMG]
     
  16. dtrotter

    dtrotter New Member

    I dont run uebimiau, but from what I have read you access it by going to:

    http://whatever.com/uebimiau

    I am running ubuntu 6.0.6 and really like it. I have built MANY servers, and this is by far my favorite build.

    Devin
     
  17. tommytomato

    tommytomato New Member

    On this sytem is was /webmail/
    try to log in using the user I put in, hence my nick, and using the sub address
    [email protected]
    which didn't work

    I'm unsure if the system created the mail account or not :confused:

    I'm alittle lost with the hole thing

    TT
     
  18. mikey3521

    mikey3521 New Member

    First you need to Create a client, then a site, Once you have a site, Click on the Email tab for the site, and create a new e-mail user. Once you've done that it will allow you to log in.

    also: Make sure you goto "Management" -> "Settings" -> "E-mail" and place a checkmark in the Maildir box.
     
  19. falko

    falko Super Moderator ISPConfig Developer

    Try http://members.rockinghamgateway.com:81/webmail/
    Then log in with an email address of the user you created and his password.

    You can check /etc/passwd to see if the user has been created.
     
  20. tommytomato

    tommytomato New Member

    Ok I'm going to come back to this later, when I have built my servers cabnet box up

    Yes it did create the user
    Code:
    tommytomato:x:500:500:Tommy:/home/tommytomato:/bin/bash
    I was able to login into the webmail ok with the help from mike, but when sending a email it just hangs there.

    I'm more use to using tinysofa for my server, but now after reading I would like 1 running with ubuntu and the other one running Debian

    TT
     

Share This Page