Ispconfig - loading http site issue

Discussion in 'Server Operation' started by Gumbicus, Jun 9, 2011.

  1. Gumbicus

    Gumbicus New Member

    *SOLVED* Ispconfig - loading http site issue

    Hello, as a task i have been told to figure out ispconfig (on centOS 5.5) and get it working, however im beggining to think that the way the person likes the OS setup is creating issues but i believe i've fixed most of them but still have a key issue

    My setup is a virtual server within a classroom, this virtual server is centos based running ispconfig, which sits behind a virtual firewall (endian firewall) which has had bogus-priv commented out,

    When i access this server through the firewall (ports are forwarded for http and ftp) on http, an access via 192.168.57.* brings up the correct site, but on any address that site is listening for, and doesn't work when i restrict it to its internal address (, or an external one (

    Also, when it is listening on any address and i typing in the name which i have created on ispconfigs server and the slave server is definately updating, typing in (57.102) or (57.102) brings up the incorrect site which does not exist in that clients directory, the site is configured to have www as an auto-subdomain as well.

    The fixes i've made due to issues with installing it (these happen everytime but may possibly be caused by installing webmin first which the teacher requires to be installed, i don't use webmin to change dns or virtual hosts at all, just to view defaults and listening ports) are:

    • corrected the directory to find named.conf and named.conf.local
    • corrected typo in vhosts directory and set it to actual directory
    • set webbase dir and the other 2 webdir options for the folders to begin with /var/www/html, the same as httpd.conf documentroot
    • added additional symlink to be automatically created from sites-enabled to sites-available for website creation
    • changed httpd.conf to include whole sites-enabled directory instead of just the 3 link references to the hosts files in sites-available that were created with ispconfig install
    • copied the fcgi master script to directory ispconfig looks for it in

    the room works almost like an internet connection but with less stuff inbetween, i connect from my computer going through a slaved nameserver then gateway, then another gateway which have the physical virtual server boxes on them then through the firewall to the server with ispconfig, we can't upgrade to centOS 5.6 until vmware releases an update for compatibility with redhat 6, running centos 5.5 on redhat 5
    Last edited: Jun 9, 2011
  2. Gumbicus

    Gumbicus New Member

    Solved, what i did above fixed the issue, classmate made me look at my dns and he noticed it was pointed at the wrong address

Share This Page