ISPConfig/Letsencrypt and squirrelmail...

Discussion in 'ISPConfig 3 Priority Support' started by flyingaggie, Mar 12, 2017.

  1. flyingaggie

    flyingaggie New Member HowtoForge Supporter

    Hey guys,
    I've been banging my head for several days on this and can't seem to get it figured out. I updated my servers (I'm mirroring the main server with ISPConfig from the ultimate setup guide) from wheezy to jessie a few weeks ago without problems (yes, I was a little behind) along with getting ISPConfig up to the latest 3.1.2. I had been looking at doing my SSL finally and learned of the nice new easy feature in ISPConfig with lets encrypt. I seem to have correctly gotten that setup, as I'm able to add the SSL and Lets Encrypt to the sites, the certificates are created and I can access them with https and get the green padlock. The issue I'm having since doing this, however, is that I can no longer access squirrelmail. It was working fine before I started doing the SSL work and now I can no longer access it with or or any other combination. When I try the https above I get "The requested URL /index.php was not found on this server." Oh...and yes, I have the /webmail alias set (as well as the original /squirrelmail) in the squirrelmail config that is symlinked in /etc/apache2/conf.d. Both /webmail and /squirrelmail obviously end in the same result above.
    I don't remember 100% if I had tried squirrelmail again between the server update and the SSL, but I think I did and I think it worked. Either way, I can't seem to figure out what's happened. /usr/share/squirrelmail is still there as is /etc/apache2/conf.d/squirrelmail. For curiosity, I created a symlink in /webmail to the /usr/share/squirrelmail directory and was able to see the login page, but permissions kept me from logging in. So it seems everything is there and functional and my guess is I'm missing something I need to configure somewhere (guessing either general vhost or apache) to get it to run via SSL. If anyone has a thought, I'd sure appreciate it! Otherwise, my forehead may be permanently dented soon. I apologize in advance, this is my first of working with SSL, so I'm sure it's probably something stupid...but I've googled like crazy and just can't seem to find anything.
    Thanks a lot!
  2. flyingaggie

    flyingaggie New Member HowtoForge Supporter

    Ok, I finally got it figured out.
    In case anyone else has this issue, this is what worked for me. I had noticed the myphpadmin was working correctly, so I started poking around to see the differences in them. What I found was that in the conf-available and conf-enabled, there was a symlink to the myphpadmin.conf file. However, there wasn't a symlink or any reference for squirrelmail. I created similar symlinks to what myphpadmin had, restarted apache and voila, I had webmail again.
    So, unless there's a security problem with what I've done (please let me know if so as I want to fix it right), that has gotten back my webmail for my virt hosts.
    And they wonder why sysadmins drink.... ;)

    till likes this.

Share This Page