ISPCONFIG - JOOMLA - extensions (images) issue

Discussion in 'HOWTO-Related Questions' started by grazman, Jan 9, 2007.

  1. grazman

    grazman New Member

    I've installed a coupe of test sites using ISPCONFIG (on a vmware test machine with the precompiled image).

    With the exception of not having a spec file to properly re-issue the certificate (it is not in the standard place, but hey, it' only a test).

    I can set up a user, create sites, FTP content, etc. no problem.

    As an example, if I create a brand new site it works fine. If I add a component/module there is an issue with permissions on ISPCONFIG.

    I get:

    -----
    "403 Forbidden"

    The following error occurred:

    You are not permitted to access the requested URL

    Please contact the Webmaster with any queries.
    -----

    This happens with multiple components/modules. And it seems to only relate to "images". They are not broken links, they simply will not show up in the page. I am sure the relative link, live site config and DNS are working exactly as they should.

    It only happens when you add a module into the Joomla (virtuemart fails to show any images, same with Jevents). If I install the virtue ecommerce edition of Joomla it's fine. But if I add a module AFTER the original install, it still fails to show images and looks cosmetically like a permissions issue somewhere.

    Does anyone have any insight on this? I am installing with the same user that owns the web site, I have also checked the permissions on the directory. I works fine on other control panels, just not with ISPCONFIG in the manner I have it deployed to test. Any ideas?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    This might be related to Joomla's .htaccess file. Search for "joomla .htaccess" and "joomla ispconfig" with the forum's search function. You should find some interesting threads. :)
     
  3. grazman

    grazman New Member

    Definitely a "rpermissions" issue.

    This is my first post. After I submitted I realize it was in the wrong place. Sorry.

    I believe I have it figured out. It was not an htacces issue, it was stranger than that. If I set the rights for the directories to "755" and contents to "644", it works. If I do it in the directory above that, recursive, it does not. Does anyone have any answer for that? Again, I am using the VMWARE image posted at their site.

    As I was trying to pull the image through the browser directly and getting the "403" error, it seemed that .htaccess was not the issue, because it is as defaults and I have not enabled SEF or any 3rd party SEF modules.

    If I change the CHMOD in the JOOMLA config (Site>Global Configuration>Server) it will work (the how-to does not address this so I assumed the defaults would work properly). It seems the limited permissions on the directories negate the ability to use the contents (images).
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Maybe you did a
    Code:
    chmod -R 644 *
    in the parent directory? That way, also all subdirectories get 644 permissions, but directories must always be executable (like 755 or 775).
     
  5. domino

    domino New Member

    Some files created through Joomla's admincp will automatically give it 755 and sometimes 777 perms. Joomla also chowns the files and directories it creates when installing modules and components, making it almost impossible to edit and add files via ftp client.
     
  6. lostmail

    lostmail New Member

    Installed joomla - can not install components, modules...

    I installed joomla successfully in var/www/web20/web/home as decribed in the manual in this forum here.

    All seemed to be fine.

    But now I try to install some modules/componentes - not possible.

    i.e. com_joomlaxplorer.zip:

    It seems that joomla has no permissions to install files....

    when I look with FTP in components there is a new directory "com_joomlaxplorer" but it is empty.

    Is ISPConfig not "Joomla-Compatible" ? Or something wrong in server-configuration ?

    Owner of directory "com_joomla" is "www-data" - is that correct ?
     
  7. Hans

    Hans Moderator ISPConfig Developer

    If the user www-data is the owner of the folder, you do not have access to that folder via FTP.

    You can considder to change the permissions as described here:
    http://www.howtoforge.com/forums/showthread.php?t=9345&highlight=joomla
    I have good experience with these permission settings.

    You also can work with suphp. Information about that can be found in the forums.
     
  8. lostmail

    lostmail New Member

    Yes - but if i install a component the owner is www-data - what is the reason that joomla doesn`t insert files into that new by joomla created directory.

    The new folder ist created but empty.

    You can see - web49 is the user of root and the one created folder "com_joomlaxplorer" ist user www-data.

    Joomla system creates the folder but than nothing more happens - no files in it...
     
  9. domino

    domino New Member

    Either delete the components and modules through ftp and reinstall them through administration or chown -r 4096:4096 every folder and file in components and module both in admin and joomla root directories.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    The new folder is owned by www-data, but when you log in with FTP, you are logged in as the user web49_1. That's why you can't upload to that folder with FTP. You could run
    Code:
    chmod 777 com_joomlaxplorer
    to solve the problem.
     
  11. vruz

    vruz New Member

    Joomla Security Issue

    Isn't it a security risk to give full permission to the world on a joomla folder.
    Somebody says anyone could thus "upload something to your folders via joomla forms".
    On your opinion, is this an issue we should pay attention to?
    Thanks.
     
    Last edited: Jun 9, 2007
  12. falko

    falko Super Moderator ISPConfig Developer

    Yes, if you have other shell users and don't use PHP Safe Mode.
    The other solution would be to run
    Code:
    chown web49_1:web49 com_joomlaxplorer
    , but then Apache can't upload into that directory anymore...
     

Share This Page