ispconfig job queue not processing

Discussion in 'ISPConfig 3 Priority Support' started by parad1se, Sep 16, 2020 at 9:16 AM.

  1. parad1se

    parad1se New Member HowtoForge Supporter

    Hello, first of let me say that I am very new to all this linux stuff, so I followed The Perfect Server guide for Ubuntu 20.04, and everything worked fine for about a day, I added a website, set my dns and everything was working great, today I was following a guide to get SSL on ispconfig page and after creating a site I noticed it was taking a long time in queue, I did a few more tasks and I noticed the queue wasn't moving and it was in fact stuck.

    I followed the "Debugging of ISPConfig 3 server actions in case of a failure" and this is what with /usr/local/ispconfig/server/server.sh


    16.09.2020-06:25 - WARNING - There is already a lockfile set, but no process running with this pid (84044). Continuing.
    16.09.2020-06:25 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    16.09.2020-06:25 - DEBUG - Found 48 changes, starting update process.
    16.09.2020-06:25 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    16.09.2020-06:25 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    16.09.2020-06:25 - DEBUG - safe_exec cmd: chattr -i '/var/www/clients/client1/web2' - return code: 0
    16.09.2020-06:25 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client1/web2' - return code: 0
    16.09.2020-06:25 - DEBUG - safe_exec cmd: df -T '/var/www/clients/client1/web2'|awk 'END{print $2,$NF}' - return code: 0
    16.09.2020-06:25 - DEBUG - safe_exec cmd: which 'setquota' 2> /dev/null - return code: 0
    16.09.2020-06:25 - DEBUG - safe_exec cmd: setquota -u 'web2' '0' '0' 0 0 -a &> /dev/null - return code: 0
    16.09.2020-06:25 - DEBUG - safe_exec cmd: setquota -T -u 'web2' 604800 604800 -a &> /dev/null - return code: 0
    16.09.2020-06:25 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client1/web2' - return code: 0
    16.09.2020-06:25 - DEBUG - Verified domain ns332869.ip-37-187-125.eu should be reachable for letsencrypt.
    PHP Fatal error: Uncaught Error: Call to undefined function get_domain() in /usr/local/ispconfig/server/lib/classes/letsencrypt.inc.php:385
    Stack trace:
    #0 /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php(1275): letsencrypt->request_certificates()
    #1 /usr/local/ispconfig/server/lib/classes/plugins.inc.php(120): apache2_plugin->update()
    #2 /usr/local/ispconfig/server/mods-available/web_module.inc.php(139): plugins->raiseEvent()
    #3 /usr/local/ispconfig/server/lib/classes/modules.inc.php(302): web_module->process()
    #4 /usr/local/ispconfig/server/lib/classes/modules.inc.php(235): modules->raiseTableHook()
    #5 /usr/local/ispconfig/server/server.php(180): modules->processDatalog()
    #6 {main}
    thrown in /usr/local/ispconfig/server/lib/classes/letsencrypt.inc.php on line 385

    I tried fixing the PHP Fatal error but without success, any help would be greatly appreciated. Thank you.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's an issue in the current beta version. Run:

    ispconfig_update.sh

    choose the nightly version as an update target.
     
  3. parad1se

    parad1se New Member HowtoForge Supporter

    Fixed! You are a godsend, thank you!
     

Share This Page