ISPConfig ispcfg3 module error

Discussion in 'Installation/Configuration' started by simonfr, Dec 15, 2015.

  1. simonfr

    simonfr New Member

    Hi all
    I'm trying to setup the ispcfg3 module since some days and I have one error which persist. This error show when I active DNS zone creation. In precedent post the creator of the module say it's translation error.
    https://www.howtoforge.com/communit...ig-module-for-whmcs.67824/page-12#post-334326
    Code:
    [Tue Dec 15 18:07:17.982586 2015] [fcgid:warn] [pid 7958] [client 141.101.64.83:47568] mod_fcgid: stderr: PHP Warning:  include(/usr/local/ispconfig/interface/lib/lang/.lng): failed to open stream: No such file or directory in /usr/local/ispconfig/interface/lib/classes/tform.inc.php on line 134
    [Tue Dec 15 18:07:17.982726 2015] [fcgid:warn] [pid 7958] [client 141.101.64.83:47568] mod_fcgid: stderr: PHP Warning:  include(): Failed opening '/usr/local/ispconfig/interface/lib/lang/.lng' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/lib/classes/tform.inc.php on line 134
    [Tue Dec 15 18:07:17.982755 2015] [fcgid:warn] [pid 7958] [client 141.101.64.83:47568] mod_fcgid: stderr: PHP Warning:  include(lib/lang/en_dns_soa.lng): failed to open stream: No such file or directory in /usr/local/ispconfig/interface/lib/classes/tform.inc.php on line 141
    [Tue Dec 15 18:07:17.982777 2015] [fcgid:warn] [pid 7958] [client 141.101.64.83:47568] mod_fcgid: stderr: PHP Warning:  include(): Failed opening 'lib/lang/en_dns_soa.lng' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/lib/classes/tform.inc.php on line 141
    [Tue Dec 15 18:07:18.016035 2015] [fcgid:warn] [pid 4553] (104)Connection reset by peer: [client 141.101.64.83:45778] mod_fcgid: error reading data from FastCGI server
    [Tue Dec 15 18:07:18.016178 2015] [core:error] [pid 4553] [client 141.101.64.83:45778] End of script output before headers: index.php
    Thanks for your help,
    Simon
     
  2. simonfr

    simonfr New Member

    Up please
     
  3. webguyz

    webguyz Member HowtoForge Supporter

    If no one else is having this problem then it must be your environment. Did you check and see if the files exist as in the error message you showed us?

    Setup a test system with a plain vanilla ISPConfig system and see if the problem re-occurs. That's what I would try if others are successfully running this script without encountering this problem. Good Luck!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    And if you think thats it's a translation error, then switch to english language and check if the error still occurs.
     
  5. simonfr

    simonfr New Member

    Hi, I've tried with an other instance and it works without any problem. I've check in config.inc.php server and interface file and all are on "en" like that :
    Code:
    //** Default Language and Timezone
    $conf['language'] = 'en';
    $conf['debug_language'] = false;
    $conf['language_file_import_enabled'] = true; // Bool value: true / false
    Any other idea ? I've tried to check zone ect... I see the error only when I ask to create DNS zone.
     
  6. webguyz

    webguyz Member HowtoForge Supporter

    What about the config section. What do you have for the DNS options? Does the template exist? Is the syntax correct?
     
  7. simonfr

    simonfr New Member

    For the DNS options I've this :
    Code:
    ns1.mydomain.com,ns2.mydomain.com,webmaster,2,5.135.***.***
    The syntax ix :
    Code:
    Syntax: NS1,NS2,Emailname,Templateid,Zone IP Address
    eg: ns1.domain.tld,ns2.domain.tld,webmaster,1,123.123.123.123
    My DNS template (ID:2) is :
    Code:
    [ZONE]
    origin={DOMAIN}.
    ns={NS1}.
    mbox={EMAIL}.
    refresh=7200
    retry=540
    expire=604800
    minimum=86400
    ttl=3600
    
    [DNS_RECORDS]
    A|{DOMAIN}.|{IP}|0|3600
    A|www|{IP}|0|3600
    A|mail|{IP}|0|3600
    NS|{DOMAIN}.|{NS1}.|0|3600
    NS|{DOMAIN}.|{NS2}.|0|3600
    MX|{DOMAIN}.|mail.{DOMAIN}.|10|3600
    I've tried to change template_id but it show the error like when the template dont exist :
    Code:
    SOAP Error: error_origin_empty<br />error_ns_empty<br />error_mbox_empty<br />error_refresh_empty<br />error_retry_empty<br />error_expire_empty<br />error_minimum_empty<br />error_ttl_empty<br />
     
  8. webguyz

    webguyz Member HowtoForge Supporter

    If you have a ISPConfig server with the DNS service running defined in your WHMCS server groups setup for ispcfg3 server then I don't see anything wrong with your setup.
     
  9. simonfr

    simonfr New Member

    In tform.inc.php at ligne 134 I see : this variable cause the problem : $_SESSION['s']['language']
    How is defined this variable ? How I can change it ? It seems it is null.
     
  10. MDylan

    MDylan New Member

  11. simonfr

    simonfr New Member

    I've tried to manually do the "dns_templatezone_add" and I get the same error. When I've commented this line :
    Code:
    $dns_id = $client->dns_templatezone_add( $session_id, $client_id, $dnstemplate, $domain, $zoneip, $nameserver1, $nameserver2, $soaemail );
    The error disapear. The cname, a ... creation are ok. I don't know how resolve this.
    Someone found a solution or have an idea can help me ?
     
  12. romlaum

    romlaum New Member

    Hi did you find a solution ? Exactly the same problem here.
     

Share This Page