ISPConfig isn't redirecting.

Discussion in 'Installation/Configuration' started by demortes, Mar 27, 2007.

  1. demortes

    demortes New Member


    Well, for those that saw my old post, fixed my problem by reinstalling the OS, and ISPConfig (DNS and ISPConfig thread).

    Now a new problem arises. I got it all up and running, but now the dang thing wont redirect to the proper directory. For example. go to

    Any clues where to fix this?
  2. demortes

    demortes New Member

    Found out that ISPConfig isn't writing the correct DocumentRoot... it's writing it to /var/www/... a hand here please?
    Last edited: Mar 27, 2007
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    /var/www is the correct document root for ISPConfig websites. If you have old websites, copy them to the new directories created by ISPConfig.
  4. demortes

    demortes New Member

    Are you sure? Try going to the page... it gives me an ftp like directory listing...

    DocumentRoot should be /var/www/web3/web, not /var/www as far as I can tell? Then again, I'm kinda new to Apache configuration files thus why I wanted a system to automate it for me.
  5. Hans

    Hans Moderator ISPConfig Developer

    I had a look at it and i found out that your /var/www folder is missing.
    The default folder to store your websites should be /var/www but i think you've set it to /var/

    The result is that your default index.html of your website is published here:

    Probably there is also something wrong with your permissions, because it is possible to browse trough whole /var/ !

    Within ISPConfig click on Manager > Server > Settings > Web(tab).

    What is the Document Root mentioned here?
    Please set it to /var/www if it is not.
    Last edited: Mar 27, 2007
  6. demortes

    demortes New Member

    /var/www is correctly installed. /var/www/ does exist.
  7. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    , and what's in Vhosts_ispconfig.conf?
  8. demortes

    demortes New Member

    eth0      Link encap:Ethernet  HWaddr 00:E0:B8:30:D9:9A
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::2e0:b8ff:fe30:d99a/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:194291 errors:0 dropped:0 overruns:1 frame:0
              TX packets:40025 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:29459455 (28.0 MiB)  TX bytes:15534247 (14.8 MiB)
              Interrupt:9 Base address:0x2c00
    lo        Link encap:Local Loopback
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:15085 errors:0 dropped:0 overruns:0 frame:0
              TX packets:15085 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:853937 (833.9 KiB)  TX bytes:853937 (833.9 KiB)
    vhost_config.conf is blank.... located at /etc/apache2/vhosts/Vhosts_ispconfig.conf. I thought this was strange. It happened after I deleted all the sites and recreated them...
  9. demortes

    demortes New Member

    Before you ask....
    -rw-r--r-- 1 root root 0 2007-03-27 14:32 Vhosts_ispconfig.conf

    RW for root, R for group and anyone. Root owns it... is this what it should be?
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Are there copies of the file Vhosts_ispconfig.conf in the same directory with a recent date appended?
  11. demortes

    demortes New Member

    There was, until I got frustrated and did a rm -rf /
  12. romz169

    romz169 New Member

    i am also having the same problem. i posted it in another thread, here is the content:

    I have followed the ubunto server howto and installed ISPconfig. I am able to connect just fine to the server. But i have created 2 sites and anytime i try to go to one it drops me in /var/www and does not dirrect me to the web# folder it should be. I have checked the Vhosts_ispconfig.conf file and both sites have it dirrected to their web# folder. It also lists the shared web in witch it should go to if no site if found. But alas it is not working.

    I have checked the Vhosts file and it has the correct information in it. It has a default that looks like it is supose to send it to /var/www/sharedip and then the other DocumentRoot is listed as /var/www/web9/web..... dont know what to do from here
  13. romz169

    romz169 New Member

    Just a shot in the dark...

    It looks like httpd is using the /root/ispconfig/httpd/conf/httpd.conf file as its configuration.. But ispconfig write to /etc/apache2/vhosts/Vhosts_ispconfig.conf

    I am no expert at all, but when i do a "grep Vhosts_ispconfig.con /root/ispconfig/httpd/conf/httpd.conf" it does not find any mention of that file....

    i really dont know where to go from here... any help would be appreciated
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up to totally different things! ISPConfig uses 2 apache webservers, one server on port 81 which uses the config file /root/ispconfig/httpd/conf/httpd.conf and is for the controlpanel only. The other apache, that serves the webpages, includes the file /etc/apache2/vhosts/Vhosts_ispconfig.conf in its configuration file.

    Thats correct, do NOT add it there.
  15. romz169

    romz169 New Member

    as posted in another thread:

    ok, I followed the guide on installing unbuntu server and then i installed ispconfig. This all went well and I can log into the server on port 81. I start configuring sites and ispconfig writes them to /etc/apache2/vhosts/Vhosts_ispconfig.conf but when i go to it drops me into the /var/www folder and i can see the file system structure. i can then navigate to the web5 folder and then to web and it will display the page but does not correctly dirrect me there. Here are snipits from the Vhosts config file.

  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Are there copies of the file /etc/apache2/vhosts/Vhosts_ispconfig.conf with a date appended to the name in the same folder?
  17. demortes

    demortes New Member

    I'm guessing there is, because this is exactly what was happening to me. I'll be setting up my server AGAIN today, I'll keep you posted.
  18. romz169

    romz169 New Member

    no, there are 2 files in the vhosts directory Vhosts_ispconfig.conf and Vhosts_ispconfig.cong~
  19. demortes

    demortes New Member

    Same thing.... vhost_ispconfig.conf to follow:

  20. demortes

    demortes New Member

Share This Page