ispconfig is not writing secondary zone files

Discussion in 'General' started by bkilinc, Feb 17, 2014.

  1. bkilinc

    bkilinc Member

    changes in secondary zone records in ispconfig are not written to slave files in '/etc/bind/slave'.
    this is a rather strange problem for me, as this was working before !! and the server is still serving as a secondary DNS server. Bind is updating slave files from primary server, all slave files have recent dates. so there is no problem with existing slave zone files. Just, I cannot add new secondary zones or edit existing ones with ISPConfig.

    I tried to resync DNS records, only the primary records are resynced and they are updated in '/etc/bind/'. no information about slave zones.

    I changed the permissions of slave directory, tried to resync again nothing changed.

    I guess, this is related to an update, but I cannot find any clues to solve it.
  2. bkilinc

    bkilinc Member

    solved :)

    at the end of the day, I found out that there were domain conflicts in my DNS records. Some same domains are defined as both primary and secondary.

    I just find it by guessing. But the problem is solved. Thanks for great software.

Share This Page