Ispconfig is not saving to the proper Vhosts_ispconfig.conf file

Discussion in 'Installation/Configuration' started by dsadm, Jun 7, 2007.

  1. dsadm

    dsadm New Member

    I have noticed when I update server/site info in the Ispconfig web interface the settings are not saved back to the proper Vhosts_ispconfig.conf in /etc/apache2/vhosts but instead they are saved to a new file Vhosts_ispconfig.conf_07-06-07_00-02-45 and I all new configurations are NOT used and appache2 does not see the new changes because of the new file creation.

    Is there a way to change this? It used to work properly but of late it has not. I have updated Ispconfig to the 2.2.13 version and the issue still remains.

    Thanks for any help.

    -Adam
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. dsadm

    dsadm New Member

    Thanks Till I did follow the sujustions you posted with:

    This is my result of httpd -t

    # httpd -t
    Syntax error on line 125 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    Invalid command 'suPHP_UserGroup', perhaps mis-spelled or defined by a module not included in the server configuration


    my /home/admispconfig/ispconfig/lib/config.inc.php shows this:


    $go_info["server"]["sudo_du_enabled"] = 0; // enable sudo for gathering website file usage
    $go_info["server"]["apache2_php"] = 'suphp'; // 'filter' = set PHP filters, 'addtype' = Set PHP addtype or 'both' = Set Filter + Addtype, suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


    and my log shows this:

    Thank you Till for your help. I have read the other forums but still have issues with the suPHP_UserGroup.

    - Adam
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The error means that you enabled suphp in ISPConfig but missed to install or load mod_suphp in your apache webserver.

    Either you switch of suphp in ISPConfig or install mod_suphp in your apache server.
     
  5. dsadm

    dsadm New Member

    Till,

    I am using apache2 and in my mods-endabled directory I have the link:

    lrwxrwxrwx 1 root root 39 2006-12-08 00:22 suexec.load -> /etc/apache2/mods-available/suexec.load
    lrwxrwxrwx 1 root root 38 2007-04-05 18:01 suphp.load -> /etc/apache2/mods-available/suphp.load

    I am using Ubuntu edgy on PPC and I can not find a mod_suphp but I do have suphp that is loaded when I start apache2.

    I have also tried creating an empty Vhosts_ispconfig.conf file and apache starts up just fine. What are causing the issues when I have Ispconfig running is the line: suPHP_UserGroup nobody web2.

    suPHP_Engine on
    suPHP_UserGroup nobody web2
    AddHandler x-httpd-php .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-php



    I don't know what creates the line in the IspConfig control panel but from all the research I have found out that the modle is there. I am a bit perplexed.

    -Adam
     
  6. dsadm

    dsadm New Member

    OK,

    After spending an entire day and very late tonight working on this issue I have done the following:

    I have been reconfiguring php5 apache2 suphp and things only got worse not better so I removed all forms of php from the system and then just loaded the apps back that used php and apt-get installed all the proper php dependencies.

    Sadly I am still left at the begining with this error when I restart apache:

    # /etc/init.d/apache2 start
    * Starting apache 2.0 web server... Syntax error on line 125 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    Invalid command 'suPHP_UserGroup', perhaps mis-spelled or defined by a module not included in the server configuration
    [fail]

    The mod_suphp is installed but as far as I can remember this started to happen when I upgraded ispconfig.

    I have removed the contents of Vhosts_ispconfig.conf with the file = 0k and restarted apache2 and it worked just fine. I am really, really at a loss with this error and it has been pulling me away from my other work. Sadly. Any help and I mean any help regarding this issue will be so welcomed at this point.

    -Adam
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Do you use
    Code:
    $go_info["server"]["apache2_php"] = 'suphp';
    in /home/admispconfig/ispconfig/lib/config.inc.php?
     
  8. dsadm

    dsadm New Member

    Yes.. I had it set to $go_info["server"]["apache2_php"] = 'suphp'; from the very begging but it still did not make a difference.

    Thank you very much for the sujustion.

    -Adam
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ISPConfig version do you use? Have you modified anything within the ISPConfig sources or added additional users to the groups created by ISPConfig manually?
     
  10. dsadm

    dsadm New Member

    Till,

    OK. I have removed the whole apache2 server and all files and purged all php files from the system. I reinstalled ispconfig and still have my control panel. I am not getting any errors as I did after some grueling work. However after reinstalling some software needed for the web system I am again getting some odd behavior in the vhost directory related to the naming of the backup Vhosts... file.

    My Stats for the system are:
    Platform: PPC 7400 (mac)
    OS: Ubuntu feisty (upgraded)
    IspConfig version: 2.2.13
    apache2: 2.2.3-3.2b

    httpd -t gave me system OK

    Right after the reinstall of apache, egroupware, and proper php files the Vhosts_ispconfig.conf file was updated upon every proper change in the control panel and the proper Vhosts_ispconfig.conf~ was also created without any the previous errors.

    At this point I did not include suphp.conf or suphp.load in the mods-enabled dir so suphp was not running on the server.

    However bring in some of the previous files used on the server made ispconfig now to instead of creating the Vhosts_ispconfig.conf~ file it now creats the file with the date and time. This would be OK but with every change in the crontrol panel saves the backup with new date and time and it does not delete the old Vhosts backup file thus filling up the directory full of backup files.

    I now created the suphp links in mods-enabled and I did not receive any http errors but still noticed the backup vhosts issue continues.

    I have since purged the newly installed files from the time when the backups were saving with date and time and sadly it continues to save the Vhosts file without the '~'. I have also backed out the suphp modules out of apache2 and the vhosts issue still continues.

    Now I am really at a lost as to what is going on.

    -Adam
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig creates only files with a date appended if your configuration contains an error so that the apache webserver did not start anamore. So you tested most likely the wrong files as ISPConfig never renames file if httpd -t gives the result OK.

    You added a configuration change that prevented apache from starting, undo this change as you told above that it was working before you used the old config files from your broken installation.
     
  12. dsadm

    dsadm New Member

    OK. I found the troublesome issue. In the section where Apache Directives are found in each web domain I had included some extra info in one domain for egroupware. When I remmoved it from ispconfig the proper backup file ending with '~' is working again all is well again with ispconfig. Now it is just reworking egroupware to work again.

    # httpd -t
    Syntax OK

    Thanks Till for your your responses and help.

    -Adam
     

Share This Page