ISPConfig & Internal Domain

Discussion in 'Installation/Configuration' started by an0key, May 22, 2007.

  1. an0key

    an0key New Member

    Hiya,

    Have installed CentOS5, and followed the guide on how to prepare it for the "perfect setup" I then proceeded to install ISPConfig ( I also needed to install Flex before the installer would play nice ).

    Anyways all has been installed, however I cannot access it via any web browser.

    It is setup on the dns as CentOS5.an0key.local and I can get into the 80 port of the webserver fine from any machine or browser, however 81 just times out.

    Even on the actual linux box, if I telnet the 81 using the ip it dies, the only way it works is if I go through using 127.0.0.1

    Any ideas? or where to start looking?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Flex is installed in all perfect setup guides. Maybe you had a other base package selection.

    Please post the output of:

    iptables -L

    are you sure that you deactivated SELinux?
     
  3. an0key

    an0key New Member

    the out put is

    Code:
    [[email protected] vhosts]# iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    
    am pretty sure SE is disabled, how would I check?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Run: system-config-securitylevel

    Please post the output of:

    netstat -tap | grep ispconfig

    Please try to access the controlpanel with the firefox webbrowser, some other browser especially IE do not show warnings if a SSL certificate is corrupt.

    Have you tried to restart the ISPconfig server?

    /etc/init.d/ispconfig_server restart
     
  5. an0key

    an0key New Member

    have run the security level and it is disabled, and SE is too.

    output

    Code:
    [[email protected] vhosts]# netstat -tap | grep ispconfig
    tcp        0      0 *:hosts2-ns                 *:*                         LISTEN      19420/ispconfig_htt
    
    and yes have tried restarting.

    Have tried a number of web browsers incl firefox and ie... in addition to telnet (windows and linux).. no joy
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check which IP is asshined to your server with the "ifconfig" command. Then open in your browser:

    https://123.123.123.123:81/

    where you replace the IP with the IP of your server.
     
  7. an0key

    an0key New Member

    This was the first thing I tried... no luck.
     
  8. an0key

    an0key New Member

    Also if I logon locally to the machine and open it in firefox, all I get is that the certificate is corrupt error -8182
     
  9. an0key

    an0key New Member

    anyone have any idea?
     
  10. falko

    falko Super Moderator ISPConfig Developer

    You must recreate the certificate as shown on http://www.howtoforge.com/forums/showthread.php?t=121

    Please accept the default values. I think you have entered incorrect values when the certificate was created for the first time.
     
  11. an0key

    an0key New Member

    I have followed the guide and still get the same message when i entered the information for me.. what do you mean by default values?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    When you run these commands:

    Code:
    openssl genrsa -des3 -passout pass:yourpassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
    openssl req -new -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
    openssl req -x509 -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
    openssl rsa -passin pass:yourpassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
    chmod 400 /root/ispconfig/httpd/conf/ssl.key/server.key
    you are prompted to enter some data. Don't enter anything, but accept the default values. Restart ISPConfig afterwards.
     

Share This Page