Ispconfig interface doesn't create database

Discussion in 'Installation/Configuration' started by lakridz, Mar 4, 2014.

  1. lakridz

    lakridz New Member

    Hi there,

    After I have updated to the latest version of ispconfig, with the new ajax interface, I cant create databases - OR ispconfig creates a record in the ispconfig tables, but does not create the mysql database.

    So first I checked that the config was correct, and the user from config was created, and worked. It did. And ofc. the connection is also fine.

    Okay, so there must be a error.. I looked into the logs, and nope no error. hmm..

    Any suggestions to debug this issue?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. lakridz

    lakridz New Member

    I have also tried running that, no help there either.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I cant help you with your issue if you do not post the debug output taht you get when you add a new mysql database.

    Did you check that the mysql root password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf is correct?
  5. lakridz

    lakridz New Member

    I know the information is limited, that is my problem. No output in error logs.. Record of the database information is getting added to the ispconfig database. But the database itself isnt getting created. Could it be a priviligede problem?

    Output of the ispconfig "common-issues" script, there is a problem with the mailserver, because I havent set it up, but that isnt the problem.:

    ##### ISPCONFIG #####
    ISPConfig version is

    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.4.6-1ubuntu1.5

    ##### PORT CHECK #####

    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "submission" entry in your postfix
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.


    [INFO] I found the following web server(s):
    Apache 2 (PID 20883)
    [INFO] I found the following mail server(s):
    Postfix (PID 19513)
    [INFO] I found the following pop3 server(s):
    Courier Mailserver (PID 20404)
    [INFO] I found the following imap server(s):
    Courier Mailserver (PID 20374)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 20477)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [anywhere]:8080 (20883/apache2)
    [anywhere]:80 (20883/apache2)
    [anywhere]:8081 (20883/apache2)
    [anywhere]:21 (20477/pure-ftpd)
    [anywhere]:22 (654/sshd)
    [anywhere]:25 (19513/master)
    [anywhere]:443 (20883/apache2)
    [localhost]:10024 (19569/amavisd-new)
    [localhost]:10025 (19513/master)
    [anywhere]:3306 (19100/mysqld)
    *:*:*:*::*:21 (20477/pure-ftpd)
    *:*:*:*::*:22 (654/sshd)
    *:*:*:*::*:25 (19513/master)
    *:*:*:*::*:993 (20392/couriertcpd)
    *:*:*:*::*:995 (20422/couriertcpd)
    [localhost]10 (20404/couriertcpd)
    [localhost]43 (20374/couriertcpd)

    The user/password in mysql_clientdb.conf is correct and tested.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not the common issues script and not the debug Info that I requested. Please read the post until the end, at the end you find a chapter that you applies to your problem and that has a link on how to debug your issue.
  7. lakridz

    lakridz New Member

    Okay a little to fast, my bad.

    Im running on ubuntu with apache2, php 5.4.6 and ISPConfig
    Like I said, there is no errors when I try create a database, I have checked logs in global apache and on the specific website logs.

    I have some notices from earlier, proberly from a apache2 restart.

    [Tue Mar 04 13:02:06 2014] [notice] caught SIGTERM, shutting down
    [Tue Mar 04 13:02:07 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Mar 04 13:02:07 2014] [notice] Apache/2.2.22 (Ubuntu) mod_fcgid/2.3.7 PHP/5.4.6-1ubuntu1.5 mod_ssl/2.2.22 OpenSSL/1.0.1c configured -- resuming normal operations - This guy seems to have the same issue, but there was not found a solution.
    Last edited: Mar 4, 2014
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, once again, we can not help you if you dont post the required debug info. I will quote you the text from the other thread:

    Please click on that link, then you get the ispconfig faq. the article there contains exact instructions waht to do to get the debug output.

    so you enable debugging and disable the cronjob, then you add a new database and then you execute the cronjob manually and post the output that you get.

Share This Page