ispconfig installed but browser unable to connect

Discussion in 'Installation/Configuration' started by rdan, Jul 14, 2007.

  1. rdan

    rdan Member HowtoForge Supporter

    The installation of ispconfig 2.2.14 was successful, but I am unable to connect to the database on port 81. Normal connection over port 80 seems to be fine. The web index on port 80 shows sharedip/ installed, but the connection to the admin interface has not been possible. Any ideas? Thanks.
     
  2. rdan

    rdan Member HowtoForge Supporter

    more details

    Sorry, I meant that I am unable to connect to the web - not the database. I set it up for ssl connection over port 81 and that is not working. The database is installed and has about 157 tables. The problem seems to be the web itself.

    All of the admin ispconfig files are located in /home. That is good, since it is not on the web root, but it seems to be bad in that they can't be accessed from a web browser.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    and
    Code:
    iptables -L
    ? Which distribution do you use?
     
  4. rdan

    rdan Member HowtoForge Supporter

    Thanks for responding. Netstat -tap produces
    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 3877/mysqld
    tcp 0 0 *:81 *:* LISTEN 4219/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 4470/proftpd: (acce
    tcp 0 0 (partial fqdn and then :domain) *:* LISTEN 3673/named (I edited out the actual computer name)
    tcp 0 0 localhost.locald:domain *:* LISTEN 3673/named
    tcp 0 0 *:smtp *:* LISTEN 4784/master
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 3673/named
    tcp6 0 0 *:imaps *:* LISTEN 3751/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 3786/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 3766/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 3731/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 4321/apache2
    tcp6 0 0 *:ssh *:* LISTEN 4039/sshd
    tcp6 0 0 *:smtp *:* LISTEN 4784/master
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 3673/named
    tcp6 0 0 *:https *:* LISTEN 4321/apache2

    I edited out three entries related to ssh.

    Iptables -L produces the following:
    iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    I'm using ubuntu 6.06.1
     
  5. falko

    falko Super Moderator ISPConfig Developer

  6. rdan

    rdan Member HowtoForge Supporter

    Thanks again. Sorry for all this hassle. I re-generated the ssl keys as per instructions in your July 21, 2005 post, but still could not connect to the server via https on port 81 or http on port 81.

    I looking at the ssl_engine_log file, I noticed two errors prior to re-generation of the certificate. The first was as follows:
    INIT: (my server name and domain name:81) RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    The second was as follows:
    Init: (my server name and domain name:81) RSA server certificate CommonName (CN) 'my name' does NOT match server name !?

    After re-generation of the certificate, the CommonName error went away, but the CA error is still there. I have done the re-generation several times, substituting a password in the places of the five lines of your provided code, and each time I get the CA error.

    The httpd.conf file has port 81 listed, and is set up to listen only on port 81. The only omission I saw in the file was that the ServerName designation line was commented out, but making it visible did not help. I also edited my desktop firewall to allow all traffic to and from my server, but that didn't help either.

    I've regenerated the entire system several times and would like to avoid doing it again if at all possible. Should I uninstall ispconfig and install it again? It appears that the option is available in the /root/ispconfig folder. Thanks again for your help.
     
  7. rdan

    rdan Member HowtoForge Supporter

    Many apologies! After thinking about it for awhile, I wondered whether the firewall at work might be blocking access to port 81 of my server. All of my work to this point was done remotely. I had checked the firewall on my desktop, but wasn't able to check the firewall at work.

    I went down to the office and installed the desktop package so that I could attempt a login from the server itself. It worked. Therefore, the port was blocked at that end. Now all I have to do is to figure out how to get putty working with openssh in ubuntu. If I can tunnel X11 inside a putty ssh session, it won't matter that the port is blocked. So far no luck. Sure hate to have to go to work to work. :D

    Ispconfig looks really good! I am looking forward to using it. Thanks again for all your help!
     

Share This Page