ispconfig installation errors

Discussion in 'Installation/Configuration' started by kcmohan, Apr 9, 2007.

  1. kcmohan

    kcmohan New Member

    Hi, I am a very junior member with minimal working knowledge of Ubuntu linux and have been trying to install a postfix mail server. Please be patient if I expose my ignorance while asking for help.

    I am running ubuntu 6.10 Edgy Eft on HP Pavillion computer.

    I installed postfix mail using howtoforge.com
    Virtual Users And Domains With Postfix, Courier And MySQL (Ubuntu 6.10 Edgy Eft).

    I have already installed all the modules for spam and virus scan as described in the howto article along with the packages required for installing ISPconfig.

    I installed the spamassassin, amaavis-new and apache2 using either apt-get or synaptic Package Manager.

    Now, I am trying to install ISPConfig and following the installation instrucitons given in ispconfig.org installation page.

    while running ./setup from the directory ../install_ispconfig/ the installation stopped during configuring Apache.

    I have no idea how to correct the situation and will appreciate any help and suggestions you can offer.

    I am giving below the error message printed on the terminal when the set up stopped.

    Configuring for Apache, Version 1.3.37
    + Warning: Your 'echo' command is slightly broken.
    + It interprets escape sequences per default. We already
    + tried 'echo -E' but had no real success. If errors occur
    + please set the SEO variable in 'configure' manually to
    + the required 'echo' options, i.e. those which force your
    + 'echo' to not interpret escape sequences per default.
    + using installation path layout: Apache (config.layout)
    Creating Makefile
    Creating Configuration.apaci in src
    Syntax error --- The configuration file is used only to
    define the list of included modules or to set Makefile in src
    options or Configure rules, and I don't see that at all:
    /root/ispconfig/openssl
    yes
    default
    no
    no
    no
    `$(SRCDIR)/apaci`
    no
    default
    default
    no
    no
    no
    yes
    no
    default
    no
    default
    default

    ./configure:Error: APACI failed
    ERROR: Could not configure Apache
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 860: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
    root@SBM1:/home/mohan/install_ispconfig# ure:Error: APACI failed
    bash: ure:Error:: command not found

    I will appreciate if you can guide me through to remedy the situation.

    Best regards,
    kcmohan
     
  2. till

    till Super Moderator

Share This Page