ISPConfig installation broken after update process failed

Discussion in 'Installation/Configuration' started by goldstift, Mar 6, 2007.

  1. goldstift

    goldstift ISPConfig Developer ISPConfig Developer

    Hi there,

    I think I need "a little" help with my ISPConfig installation. I tried to upgrade from 2.2.10 to 2.2.11 when my putty lost its connection to the server *argh*

    I thought perhaps the setup would recognize it's current status, when being restarted, so I killed the hanging processes and restartet setup script. But that again resulted in a hangtime.
    As the next try also didn't work, I removed the /root/install_ispconfig directory...
    ... well, when I extracted the archive again and ran setup it didn't recognize my existing ISPConfig installation anymore :eek:

    The files in /home/admispconfig and /var/www/ are still there but /root/ispconfig is gone. What can I do??

    Thanks for your support.
    Greets,
    Alex
     
    Last edited: Mar 6, 2007
  2. goldstift

    goldstift ISPConfig Developer ISPConfig Developer

    Ok, did it! After fixing a few things ISPConfig installed correctly and at the end of the process recognized the existing database.

    It seems like none of my work is lost.

    Thanks Falko and Till, you did a great job with that tool!

    By the way: I'm currently working on a comfortable backup-plugin/ script including server sync. Is there a list of which files are modified by ISPConfig?

    Thank you and good night.
    Alex
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Just a small hint to prevent this, if you use the commandline tool "screen" you will be able to resume a shall session that was interrupted.

    Great to hear that.

    No, but I will try to make one:

    /etc/postfix/virtusertable
    /etc/postfix/local-host-names
    /etc/passwd
    /etc/shadow
    /etc/group
    /etc/gshadow
    The named.conf file and the pri.xxxxx files which contain the DNS-data
    Vhost_ispconfig.conf
    All files and folders in the document root

    For the location of the document root and bind, etc. have a look at the fields in the isp_server database table.

    I think thats all :) Please correct me if I forgot some files.
     
  4. teveo1

    teveo1 New Member

    .. back to upgrade problems. i am now trying 2.2.11 with no luck,

    crashes on libidn

    /usr/lib/libidn.so: could not read symbols: File in wrong format
    collect2: ld returned 1 exit status

    x64 server sun v20z..

    -rwxr-xr-x 1 root root 801 Feb 12 2006 /usr/lib/libidn.la
    lrwxrwxrwx 1 root root 21 Mar 7 12:13 /usr/lib/libidn.so -> /usr/lib/libidn.so.11
    lrwxrwxrwx 1 root root 17 Apr 25 2006 /usr/lib/libidn.so.11 -> libidn.so.11.5.16
    -rwxr-xr-x 1 root root 196264 Feb 12 2006 /usr/lib/libidn.so.11.5.16



    no matter if i softlink to
    /usr/lib/libidn.so.11 or /usr/lib/libidn.so.11.5.16 i get the same format error..

    any ideas ?
     
  5. falko

    falko Super Moderator ISPConfig Developer

  6. teveo1

    teveo1 New Member

    thanks! That solved my problems!! :)

    (perhaps you could add a platform check to this stage of install script ? just a suggestion as more and more boxes now ship with x64 architecture)
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats no general x64 problem, so a platform check wont help. Its not even ISPConfig which causes this, it is a problem in the latest ClamAV versions, I hope they get it fixed so that clamav is able to compile on 64bit again without having to manipulate any symlinks.
     

Share This Page