ISPConfig Install Script

Discussion in 'Tips/Tricks/Mods' started by dclardy, Mar 17, 2011.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Really funny that you want to run your own server without willing to spend half an hour to install it properly. Good luck with using webmin, you will spend a lot more time in webmin for tasks that take a single click in ispconfig and webmin requires a good linux server knowledge to use it. But you will see it when you try to setup everything in webmin properly and securely ;) bye
     
  2. Bigdickau

    Bigdickau New Member

    hi till

    ok i will give one more go from a fresh install.

    i notice the manual and the onscreen have different setups what would recommend to follow.

    Many thanks

    Richard C
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    We have different guides for each Linux Distribution and version. The ISPConfig manual contains a multiserver and cluseter guide for Debian, but the main ppurpose of the manual is to provide a guide on how to use ispconfig and not the installation as we would not be able to cover all instruvctions for alls supported distributions in one manual.

    You said that you use Ubuntu 12.04 on your server? Then this guide is the right one for you:

    http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3

    If your server has already a ubuntu minimal installed (e.g. by your hoster), then you can skip the first steps and start with chapter 8.

    If you use a windows desktop for your work, then download the free terminal program putty to connect to your server. This allows you to copy / paset the commands from the tutorial and you dont have to type them. Pasting in putty is done with the right mouse button.

    I highly recommend that you start with a clean setup from scratch as it might by that yor install attempts for webmin altered the system in a way that will prevent ispconfig from working properly later.
     
  4. Bigdickau

    Bigdickau New Member

    hi till
    thanks for the support which i am in desperate need of.
    the base system is hp ml350 g5 server and i have loaded ubuntu 12.04 server with nothing else.
    I am following the surgestered text and i will see how we go.

    again many thanks for your support

    Richard C
     
  5. Bigdickau

    Bigdickau New Member

    hi till

    well i made it all the way big thank you to you. now if i can solve the login problem i will be very happy chappy.

    login problem is in the install config page.

    Many thanks

    Richard C
     
  6. dclardy

    dclardy Member

    I have recently update my script to have more features, and it has been combined to one command to install it now. It still supports debian and ubuntu. Please try it out and let me know what you think. I have tested it multiple times on quite a few droplets.
     
  7. Cronner

    Cronner New Member

    Really nice installer great work :)

    Have a few suggestions, repositories is us which was really slow for me durung install (Denmark) so maybe have some options for us, eu, etc repos
    and maybe select all options to start with so that the script can take care of all afterward itself?

    Also installed template and roundcube, template is really nice! but roundcube did not work, giving me:

    404 Not Found
    nginx/1.4.6
     
  8. dclardy

    dclardy Member

    What web address are you using to get to the roundcube install? It should be http://webmail.domain.com. Are you using that?
     
  9. Cronner

    Cronner New Member

    no was following the link in ispconfig was https://ip:8080/webmail
    tried a new install today and getting:
    using latest debian minimal version

    [FAIL] Starting MariaDB database server: mysqld . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . failed!
    invoke-rc.d: initscript mysql, action "start" failed.
    dpkg: error processing mariadb-server-5.5 (--configure):
    subprocess installed post-installation script returned error exit status 1
    Setting up libhtml-template-perl (2.91-1) ...
    dpkg: dependency problems prevent configuration of mariadb-server:
    mariadb-server depends on mariadb-server-5.5 (= 5.5.36+maria-1~wheezy); however:
    Package mariadb-server-5.5 is not configured yet.

    and keeps asking for new password for mariadb root
    and keep on failing to start mariadb

    something changed in the installer?

    Also, the installer should have an option to choose php 5.5 which is in dotdeb repo :)
     

    Attached Files:

    Last edited: Mar 8, 2014
  10. Cronner

    Cronner New Member

    Tried to install MariaDB on a new install and nothing else with:

    apt-get install python-software-properties
    apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xcbcb082a1bb943db
    add-apt-repository 'deb http://ftp.ddg.lth.se/mariadb/repo/5.5/debian wheezy main'
    apt-get update
    apt-get install mariadb-server

    and started with no problem so must be script?

     
  11. dclardy

    dclardy Member

    It is hard for the script to be the issue when we are using the exact same commands. The only thing that I can guess is that the mirror went down. I'll change it out.
     
  12. Cronner

    Cronner New Member

    Ok, strange, tried to change mirrors and install, same result it installs but does not start and then the installer loops.

    tried mariadb without nothing else, started fine.
     
    Last edited: Mar 12, 2014
  13. dclardy

    dclardy Member

    How much ram do you have on this system? I just ran the script on a Droplet, and I am not getting any errors there.
     
  14. Cronner

    Cronner New Member

    4gb ram, clean debian minimal, alot of hdd
     
  15. dclardy

    dclardy Member

    Not sure what the issue is. I installed it and it all works fine.
     
  16. Cronner

    Cronner New Member

    with nginx, mariadb all all the other stuff?
     
  17. dclardy

    dclardy Member

    Yes. Installed it all.
     
  18. Cronner

    Cronner New Member

    Going to try again, and if it dows not work I can give you access so you can see what's going on?
     
  19. dclardy

    dclardy Member

    Sure thing.
     
  20. budgierless

    budgierless Member

    Hi,

    Anyone know of a working dedicated ubuntu version of the script, as i used the current version in 12.04 a few times but not all functions are working correctly, like mail etc?
    EDIT: the problem is with the script itself as for some reason it has the wrong repository, currently only works for 14.04
     
    Last edited: Jan 25, 2015

Share This Page