ISPConfig Install Script

Discussion in 'Tips/Tricks/Mods' started by dclardy, Mar 17, 2011.

  1. asterinux

    asterinux New Member

    hi dclardy, first of all i want to thank you for creating this script, been looking for some automation script to install ispconfig3, i salute you for this :). I have only a follow-up question sir, is the script for CentOS complete?

  2. asterinux

    asterinux New Member

    hi dclardy, nevermind.. i already read instructions in github, thanks:)
  3. almere

    almere ISPConfig Developer ISPConfig Developer

    If you have multi IP's at your server, make sure that DNS A record has the same IP as vhost.
  4. dclardy

    dclardy New Member

    The script is not complete, but I am working on it. I don't use CentOS, and it is harder for me to get this done. I will be spinning up a test box to try and get it going.
  5. dclardy

    dclardy New Member

    Alright. It has been awhile since I have updated the script any, but I have made some major changes.

    Please let me know what you think.

    1. Add latest Debian and Ubuntu Support
    2. Added Whiptail for prompts. (Looks way cleaner!)

    In Progress:
    1. RoundCube Support
    2. Theme Installation Support
  6. Theseus

    Theseus New Member

    ISPConfig Script

    I am interested in a version of this script for openSUSE 12.3. I have not been able to get the install instructions to work. I am able to execute all the instructions for version 12.2 (with the appropriate modifications in the links), but when I run I don't get the login screen shown in the tutorial. Just two options:

    Skip to the navigation. Skip to the content.

    If anyone knows what's wrong, I would appreciate it, or a copy of that script for opensuse.
  7. dclardy

    dclardy New Member

    Alright. I have gotten RoundCube Installation support added in. It is a different bash script. Please test this out. I have several times, but I might have missed something.

    I am working on the Theme Installation part of it. Initially, I will probably only install my theme, but I am a little biased in that regard!
  8. stevenlib

    stevenlib New Member

    Some errors


    It fails on Wheezy, I get this:

    Thu Sep 26 11:55:02 EDT 2013 --2013-09-26 11:55:02--
    Thu Sep 26 11:55:02 EDT 2013 Resolving (
    Thu Sep 26 11:55:02 EDT 2013 Connecting to (||:80... connected.
    Thu Sep 26 11:55:02 EDT 2013 HTTP request sent, awaiting response... 200 OK
    Thu Sep 26 11:55:02 EDT 2013 Length: 126842 (124K) [application/zip]
    Thu Sep 26 11:55:02 EDT 2013 Saving to: `'
    Thu Sep 26 11:55:02 EDT 2013
    Thu Sep 26 11:55:03 EDT 2013 0K .......... .......... .......... .......... .......... 40% 238K 0s
    Thu Sep 26 11:55:03 EDT 2013 50K .......... .......... .......... .......... .......... 80% 449K 0s
    Thu Sep 26 11:55:03 EDT 2013 100K .......... .......... ... 100% 5.84M=0.3s
    Thu Sep 26 11:55:03 EDT 2013
    Thu Sep 26 11:55:03 EDT 2013 2013-09-26 11:55:03 (380 KB/s) - `' saved [126842/126842]
    Thu Sep 26 11:55:03 EDT 2013
    Thu Sep 26 11:55:03 EDT 2013 sh: ./ Permission denied

    Then it says the install failed in ISPConfig logs.

  9. ruchri

    ruchri New Member

    Works fine on Debian 7 64b Wheezer.

    Thank you!
    Last edited: Oct 5, 2013
  10. ruchri

    ruchri New Member

    Why restarting Apache2 manually after VPS reboot?

    There is one small issue: after each reboot of my VPS I have to restart apache2 manually: /etc/init.d/apache2 restart

    I don't understand why, so I can't find a solution for that.

    VPS, 1 GB memory - Debian 7 64bit
    Installed ISPConfig3 and Roundcube with your install scripts and there were no errors or whatsoever.
    Everything is working nice and smoothfull, as I already stated elsewhere in this topic.
  11. dclardy

    dclardy New Member

    I am not sure where you are getting this error from. I am not installing anything form that repo. My script does not include those plugins because you have to create a remote user in ISPConfig, and I have not figured out a way to do that just yet from the command line.
  12. dclardy

    dclardy New Member

    What web server did you pick? I am guessing Apache was the one, but I want to be sure. If you run this update–rc.d apache2 defaults, it should be loading itself every time afterwards. My script doesn't do anything to change that.


    I found the issue. I had placed a command in the wrong section. That has been corrected now.
    Last edited: Oct 15, 2013
  13. ruchri

    ruchri New Member

    Indeed, it is Apache2. Sorry I did not mention that in the post.

    I used the command you gave. Problem SOLVED
  14. dclardy

    dclardy New Member

    Glad that worked for you.

    I have added another script to install themes now. I have added my theme, and I will be adding some of the other good ones around here. If you know of any, send them my way.
  15. Bigdickau

    Bigdickau New Member

    hi all
    i have just tryed this addon but failed to install. all i get is /tmp/dclardy64-ISPConfig-3-debian-install-e4cf0b8$.

    i did not install debian just ubuntu.

    should i do a clean install after installing Ubuntu 12.04

    Many thanks

    Richard C
    Last edited: Jan 4, 2014
  16. till

    till Super Moderator Staff Member ISPConfig Developer

  17. Bigdickau

    Bigdickau New Member

    these are the instructions i followed

    Ubuntu Installation Instructions:

    Run this command:

    cd /tmp; wget --no-check-certificate -O ISPConfig3.tgz; tar zxvf ISPConfig3.tgz; cd *Installer*; bash
    Answer the onscreen prompts. The script stops so that you can see the appropriate answers.
    Enjoy the completed installation.

    I think there might be a typo in the script as debian is mentioned in all the setups

    Many thanks Richard c
  18. Bigdickau

    Bigdickau New Member


    further to my last post i changes the reference about Debian to Ubuntu and got this reply.

    404 not found.
    gzip: stdin: unexpected end of file.
    tar: Child returned status 1
    tar: Error is not recoverable: exiting now
    bash: cd: *installer*: no such file or directory
    bash: No such file or directory

    ready to give up on this install and i don't know why when others swear by it

    Looking forward for some replies

    Richard C
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Why dont you use the official and normal way to install ispconfig? Instead you use a third party script which is not tested by the ispconfig deveopers.

    If you ant to install ispconfig reliably, just follow the official installation instructions for ubuntu 12.04:
  20. Bigdickau

    Bigdickau New Member

    hi till
    i am new to this type of computing and have been following some of the subjection to make my lot easer. So now i have made this one. i have a choice of ISPConfig3 with 16 pages of code tobe written before running or Webmin with 3 lines of code to get up and running. guess who won. BYE

    Richard C

Share This Page