ISPConfig install gives another MYSQL couldnt be reached.

Discussion in 'Installation/Configuration' started by sund, Jan 29, 2008.

  1. sund

    sund New Member

    Followed the howto: Suse 10.3 perfect server guide and done exactly as described there.

    Ive read through the threads about this installation problem but noone seems to be giving an awnser, people just say "nevermind its working now" , so here i sit and curse for that the solution isnt being revealed :)

    anyway, netstat -tap | grep mysql
    Code:
    tcp        0      0 *:mysql                 *:*                     LISTEN    13611/mysqld
    fping localhost [email protected] server.******.homelinux.com server
    gives
    Code:
    localhost is alive
    [email protected] is alive
    server is alive
    server.******.homelinux.com is alive
    
    cat /etc/hosts
    Code:
    127.0.0.1       [email protected] localhost
    
    # special IPv6 addresses
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet
    
    ff00::0         ipv6-mcastprefix
    ff02::1         ipv6-allnodes
    ff02::2         ipv6-allrouters
    ff02::3         ipv6-allhosts
    127.0.0.2       server.*******.homelinux.com server
    
    HTML:
    
    
    Still i get whatever i try typing:
    Please enter your MySQL server:localhost
    The MySQL server you specified cannot be reached!
    tried localhost,server,server.*****.homelinux.com,127.0.0.1,127.0.0.2,and the box current ip

    and the output of my iptables is
    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination  
    
    so no rules are blocking any connections at all.

    please help :confused:
     
    Last edited: Jan 29, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    You have an @ sign in /etc/hosts.
    Please make the file look like this:

    Code:
    127.0.0.1       localhost.localdomain localhost
    [I]1.2.3.4[/I]       server.*******.homelinux.com server
    
    # special IPv6 addresses
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet
    
    ff00::0         ipv6-mcastprefix
    ff02::1         ipv6-allnodes
    ff02::2         ipv6-allrouters
    ff02::3         ipv6-allhosts
    Please replace 1.2.3.4 with your server's IP address.
     
  3. sund

    sund New Member

    didnt make the installer understand what either localhost, the box ip or anything.
    the mysql server isnt to be found, even though i can login from all thoose names and ip's ive tried in the script like.
    telnet localhost (or server (or the box ip)) 25
    and
    mysql -h localhost (or server (or the box ip)) -u root -p

    thoose both work, why cant the script understand that :(

    btw, i have apparmor disabled aswell, forgot to mention that earlier. cheers for trying to help me!
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ? What's in /etc/hosts now? Does your MySQL password contain special characters?
     
  5. sund

    sund New Member

    netstat -tap
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
    tcp        0      0 localhost.localdoma:966 *:*                     LISTEN      2910/famd           
    tcp        0      0 *:ideafarm-catch        *:*                     LISTEN      2853/rpc.rquotad    
    [COLOR="Red"]tcp        0      0 *:mysql                 *:*                     LISTEN      2651/mysqld [/COLOR]        
    tcp        0      0 *:sunrpc                *:*                     LISTEN      2831/portmap        
    tcp        0      0 *:ftp                   *:*                     LISTEN      2917/proftpd: (acce 
    tcp        0      0 server.******:domain *:*                     LISTEN      2890/named          
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      2890/named          
    tcp        0      0 server.******:pwgpsi *:*                     LISTEN      3111/ventrilo_srv   
    tcp        0      0 *:smtp                  *:*                     LISTEN      2980/master         
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      2890/named                 
    tcp        0      0 *:imaps                 *:*                     LISTEN      2787/couriertcpd    
    tcp        0      0 *:pop3s                 *:*                     LISTEN      2813/couriertcpd    
    tcp        0      0 *:10022                 *:*                     LISTEN      2698/sshd           
    tcp        0      0 *:pop3                  *:*                     LISTEN      2799/couriertcpd    
    tcp        0      0 *:imap                  *:*                     LISTEN      2764/couriertcpd    
    tcp        0      0 *:www-http              *:*                     LISTEN      4109/httpd2-prefork 
    tcp        0      0 *:domain                *:*                     LISTEN      2890/named          
    tcp        0      0 *:smtp                  *:*                     LISTEN      2980/master         
    tcp        0      0 localhost:953           *:*                     LISTEN      2890/named          
    tcp        0      0 *:https                 *:*                     LISTEN      4109/httpd2-prefork 
    
    cat /etc/hosts
    Code:
    127.0.0.1       localhost.localdomain localhost
    192.168.0.107   server.******.homelinux.com server
    
    # special IPv6 addresses
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet
    
    ff00::0         ipv6-mcastprefix
    ff02::1         ipv6-allnodes
    ff02::2         ipv6-allrouters
    ff02::3         ipv6-allhosts
    
    nope, my password contains just a-z and 0-9, but it isnt really the problem since i cant get passed the Connection to my mysql server, havent got so far as typing in username and password.
    thanks again for helping.
     
    Last edited: Jan 31, 2008
  6. falko

    falko Super Moderator ISPConfig Developer

    Not sure what the problem is... :(
     
  7. sund

    sund New Member

    same here, im guessing that the setup script is to blame.
    i downloaded the latest nightly build from the repo , but in that version suse 10.3 wasnt supported...

    also tried to download a new copy of the stable version, but with no success :(
    i guess ill have to get back to good old ubuntu and hope for better luck there.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Good choice! :)
     

Share This Page