ISPConfig install error

Discussion in 'Installation/Configuration' started by clabrown, Jan 2, 2007.

  1. clabrown

    clabrown New Member

    I believe i completed the "Perfect" Ubuntu Server setup HowTo and followed that with the ISPConfig Howto. There were problems with unstated details like development packages I needed to install which were not explicitly mentioned but eventually the install seemed to continue almost to the end with the following information, something about a password of "YES" seems to start the problem. After this I can not log into ISPConfig with "admin" "admin". Any Ideas? I think my root password, which contained the characters "!@#$" may have conflicted with the shell script. Any Ideas how I can continue from here, or do I need to reformat and start over? Thanks.

    Connected successfully to MySQL server
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
    no crontab for root
    Restarting some services...
    * Stopping Postfix Mail Transport Agent postfix [ ok ]
    * Starting Postfix Mail Transport Agent postfix [ ok ]
    * Stopping ftp server proftpd [ ok ]
    * Starting ftp server proftpd - IPv6 getaddrinfo 'ubs01.granitepost.com' error: Name or service not known
    [ ok ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Please direct your browser to

    https://ubs01.granitepost.com:81

    and log in:
    Username: admin
    Password: admin
     
  2. till

    till Super Moderator

    Did you create a database manually in MySQL that you used for the ISPConfig installation? Does your mysql root password contains special chars?
     
  3. clabrown

    clabrown New Member

    No I did not manually create any database. I was following the ISPConfig installation instructions and I don't think there was a step to manually create any database.

    My MySQL root password is the same root password that I mentioned below. It contains the characters "!@#$".

    Is the MySQL root user not the same root user of the whole machine?

    Thanks, Cla.
     
  4. falko

    falko Super Moderator

    That's the problem. It must not contain special characters. Please change it and delete /root/ispconfig and /home/admispconfig, then install ISPConfig again.
     
  5. clabrown

    clabrown New Member

    Closer perhaps, but still no joy.

    It gets further now, it does not have an error connecting or accessing the MySQL server. It still shows the PHP error in line 47 of /root/ispconfig/scripts/lib/config.inc.php

    as directed ..

    I erased the two directories.

    I believe I changed the MySQL root password to something with only letters and numbers. It seems that there are 2 users or passwords that had to be changed, one without and one with the host name specified, similar to the following from the "perfect ubuntu setup" howto:

    mysqladmin -u root password yourrootsqlpassword
    mysqladmin -h server1.example.com -u root password yourrootsqlpassword

    Now the ISPConfig install proceeds without apparent error right to the end where it has a PHP error in line 47. When I try to login to ISPConfig with Admin Admin it tells me "ERROR 101: wrong username or password". Here is a copy from the last of the install showing the error:


    Connected successfully to MySQL server
    Es ist schon eine Datenbank mit dem Namen db_ispconfig vorhanden!
    Restarting some services...
    * Stopping Postfix Mail Transport Agent postfix [ ok ]
    * Starting Postfix Mail Transport Agent postfix [ ok ]
    * Stopping ftp server proftpd [ ok ]
    * Starting ftp server proftpd - IPv6 getaddrinfo 'ubs01.granitepost.com' error: Name or service not known
    [ ok ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!FreshClam is already running!
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Please direct your browser to

    https://ubs01.granitepost.com:81

    and log in:
    Username: admin
    Password: admin

    root@ubs01:~/install_ispconfig#

    Thanks again for your help.
     
  6. till

    till Super Moderator

    Have you deleted the ISPConfig mysql database too before you reinstalled. If there is a mysql database with the same name that you entered in the ISPConfig installer, the setup will fail.
     
  7. clabrown

    clabrown New Member

    You guys are great!!

    till / falco:

    MANY THANKS!

    ISPConfig now seems to be up and running ...

    Now all I've got to do is figure out how to use it!!

    Thanks again,

    Cla.
     

Share This Page