ISPConfig .htaccess Options +Indexes

Discussion in 'General' started by davidcampbell, Mar 21, 2008.

  1. davidcampbell

    davidcampbell New Member

    I have a Debian Etch 4.0r2 running the latest version of ISPConfig (installed last weekend) + phpmyadmin module addon

    I'm having an issue with allowing Directory Indexes, all the apache servers I've worked with before (I'll admit, Im fairly noob-ish :rolleyes: ) have just let me add a .htaccess file in the directory and add the lines

    Options +Indexes
    IndexOptions +FancyIndexing

    And that will make my indexing work, but in ISPConfig I get a 500 Internal Server Error page coming up... can somebody help me :confused:
     
  2. daveb

    daveb Member

    Not sure if this is the safest way, but I added this to the apache directives feild for the site that I wanted to have indexed.
    Code:
    <Directory /path/to/dir>
        Options +Includes +Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
     
  3. davidcampbell

    davidcampbell New Member

    Thanks alot, that works nicely... but can I ask, is there anyway to allow this to work directly with .htaccess files?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    At the end of /etc/apache2/apache2.conf, you should find something like this:

    Code:
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    You can adjust that to your likings.
     
  5. bhwong

    bhwong New Member

    Is this file located under /etc/apache2/sites-enabled/000-default?

    And do I have to restart apache after editing this for it to take effect?
     
  6. bhwong

    bhwong New Member

    Apache2 show error on mixing * ports and non-* ports

    I add :80 as suggested at: http://bugtracker.ispconfig.org/index.php?do=details&task_id=672

    But I still receive the same error with :80 added:

    [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Do you use ISPConfig 2 or 3?
     
  8. bhwong

    bhwong New Member

    I use ISPConfig3
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Then your're in the wrong forum. This thread and Forum is about ISPConfig 2, which is a completely different doftware then ISPConfig 3 and everything that is posted here does not apply to your installation.
     
  10. bhwong

    bhwong New Member

    Oh, so sorry. I will repost this to the correct forum.
     

Share This Page