ISPConfig hanging while making changes

Discussion in 'ISPConfig 3 Priority Support' started by Nilpo, Jun 23, 2017.

  1. Nilpo

    Nilpo Member HowtoForge Supporter

    I've made some changes from my ISPC3 panel (changed settings on a site and added a new site). The changes are just hanging.
    The following changes are not yet populated to all servers
    • Create new website: 1
    • Update website settings: 1
    It's been hanging for awhile. I added the new site about 10 minutes ago, but the other site change was done more than a week ago.

    I'm running version 3.1.2 on Perfect Server CentOS 6.
     
  2. Nilpo

    Nilpo Member HowtoForge Supporter

    So diving into the system it looks like the changes are successful, but the messages aren't clearing.
     
  3. Nilpo

    Nilpo Member HowtoForge Supporter

    I was wrong. The database entries have been created for the site I added (it appears in the Site list in ISPC3), but the physical directories have not been created.
     
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Run /usr/local/ispconfig/server/server.sh by hand and check the output.
     
  5. Nilpo

    Nilpo Member HowtoForge Supporter

    Here's the output:

    Code:
    [[email protected] ~]# /usr/local/ispconfig/server/server.sh 
    			
    
    useradd: warning: the home directory already exists.
    Not copying any file from skel directory into it.
    finished.
    It did clear the messages and the directories have been created.
     
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Then you should check your crons. If it works when called manually then the cron seems not to be running.
     
  7. Nilpo

    Nilpo Member HowtoForge Supporter

    `crontab -l` looked good. Turns out crond wasn't running at all for some reason.
     

Share This Page