ISPCONFIG fresh install error on Ubuntu 16.04

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Mar 12, 2017.

  1. pawan

    pawan Member HowtoForge Supporter

  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Maybe your sql-server uses the unix_sockat auth plugin. This will not allow the root-user to connect to the db-server without using the socket. I did not saw any problems with this during install / update ispconfig.
    You can either create a 2nd root-user for mysql (i.e. admin):
    CREATE USER 'admin'@'localhost' IDENTIFIED BY 'pass';
    GRANT ALL PRIVILEGES ON *.* TO 'admin'@'localhost' WITH GRANT OPTION;
    and use this user during the installation

    or remove the plugin from the root-account in mysql:
    update user set plugin='' where User='root';
    flush privileges;
     
  3. pawan

    pawan Member HowtoForge Supporter

    I used this option, now I am not able to login or connect to mysql using password yes.
    Even tried changing the password - using - mysqladmin -u user-name -p oldpassword newpass
    But that didn't work either.

    As a note - I have selected password strength as strong at the time of mysql setup. is that making any difference.
    As while setting password without one uppercase letter it was not accepting the password, whereas I was selecting the default password generated by ispconfig which doesn't use any uppercase letter.
    How I can revert to password strength I have selected during setup.
     

Share This Page