ISPConfig Firewall

Discussion in 'Installation/Configuration' started by PortMan, Aug 8, 2006.

  1. PortMan

    PortMan New Member

    I'm running the latest ISPConfig on a FC5 box. I wanted to restart the ISPConfig firewall and clicked the "Restart" on the services page. Now, the firewall is always listed as "Restart" and if I try to change it to "On" it keeps giving me the error:
    "Your changes cannot be saved because this item is currently being updated. Please try again later."

    It has been several hours now and still I can't change it. I even tried restarting the ISPConfig service and even rebooted the server.

    Any help would be great!

    Thanks.
     
  2. PortMan

    PortMan New Member

    Update

    I tracked down the isp_dienste table and found the "Status" was "u" so I changed it to NULL and also changed the firewall to "on".

    That seemed to fix my problem, I thought. It seems that when I make any changes to the services, the "u" never goes away.

    Also, I added a port to the firewall (port 6433) and it won't allow me to connect. When I disable the firewall using /etc/init.d/bastille-firewall stop I can get through.

    I'm using FC5, PHP5.0.22
    Any thoughts?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Do other changes, e.g. adding an email account, work? Do you get any errors in /home/admispconfig/ispconfig/ispconfig.log ?
     
  4. PortMan

    PortMan New Member

    everything else works fine and there are no errors in the log.

    I think i'm going to just turn off the ispconfig firewall and use the one in linux. How do I keep the firewall from starting when the system reboots?

    Thanks.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    You can edit /root/ispconfig/scripts/shell/firewall.php.
     
  6. PortMan

    PortMan New Member

    Thanks for the reply, but I looking at the file, I have no idea what I need to change to make it not start. Can you guide me?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Replace these lines:

    PHP:
    if($dienst["dienst_firewall_status"] != "off"){
      
    $mod->system->daemon_init("bastille-firewall""restart");
    } else {
      if(
    is_file("/var/lock/subsys/bastille-firewall")) $mod->system->daemon_init("bastille-firewall""stop");
    }
    with this one:
    PHP:
    if(is_file("/var/lock/subsys/bastille-firewall")) $mod->system->daemon_init("bastille-firewall""stop");
     

Share This Page