Ispconfig firewall

Discussion in 'Installation/Configuration' started by ijujym, Aug 26, 2012.

  1. ijujym

    ijujym New Member

    Hello all,
    Here is my story, during the install Iv changed default ports for ssh and ispconfig panel. Every thing was ok but yesterday I have checked the firewall settings at ispconfig panel (saved the default settings as they were there). Currently Im not able to connect both to ispconfig and ssh
    Code:
    ssh: connect to host 1.2.3.4 port 000: Connection timed out
    
    Have I just closed the ports for connections in ispconfig firewall settings?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, if you enabled the firewall without opening your custom ports beafore you activated it, then you locked out yourself from the server. If you have directbaccess to the server, then stop the bastille firewall with its script in /etc/init.d/ and then configure the ports in ispconfig.
     
  3. ijujym

    ijujym New Member

    Thank you, very much! it worked
     
  4. davez

    davez New Member

    Hello, thanks for the nice work!:)
    I installed all went just well , untill i also clicked on the firewall setings (predifined) in de ISPConfig......i'm out and cant get back in:(
    I can for a moment when i stop the firewall, i dont seem to understand where i can configure the ports in ispconfig? just cant seem to understand what to do?
    How can i get this working again and with the firewall enabled in ispconfig? (i know above awnser seems to do it but i noop dont get it?):(
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Firewall settings in ispconfig are in the system module. The ispconfig firewall dont block any ports when it is unconfigured. maybe you run a second firewall that interferes with the bastille base rules.
     
  6. davez

    davez New Member

    Hi Till,
    Thanks for the quick responce!:)
    I installed everything new from scratch on a dedicated server (here @ home) and used the tut from your site, step by step.
    All was fine until i klicked on : add firewall record under/ ispconfig / server / firewall. after that all is closed?
    now when i remove that record in ispconfig / server/ firewall , it isnt helping me some were i kept blocked?
    If there is any other firewall running in the server it must have came with your installation?
    Some how Bastille has rote some rules that i cant seem to find and get rid off?
    (maby i will install the server from scratch again?:()
    Greets :)
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux distribution do you use? When you use a root server then your ISP might have installed a firewall in its base image.
     
  8. davez

    davez New Member

    Last edited: Jan 20, 2016
  9. DDArt

    DDArt Member

    You might want to consider a LTS version of a Distro. You'll come to find out few months down the road that you might have to do a major upgrade and might break things. LTS distros will give you 5 years of support when it comes to security/updates.
     

Share This Page