ISPConfig fails on clamwin

Discussion in 'Installation/Configuration' started by delgado2061, Jun 6, 2010.

  1. delgado2061

    delgado2061 New Member


    I have ISPconfig-2.2.35 and it don't upgrade to 2.2.36 fail on the clamav installation I am running fedora 9 ISPConfig-2.2.35 so I run the ISPConfig-2.2.35 again them evevrything was back to normal. try to install the clamav newer version and it quits on me. so I have my server running back ISPConfig-2.2.35.

  2. Mark_NL

    Mark_NL New Member

    If you look closely, you'll notice the error
    "cannot find -lstdc++
    That means the installer/compiler can't find libstdc++

    So install libstdc++ with your package manager, and start the installation again.
  3. delgado2061

    delgado2061 New Member

    as you can see my is already install. I run the perfect server fedora 9 for year now. this never happen to any update. so the installation is looking somewhere else.

    Last edited: Jun 7, 2010
  4. Mark_NL

    Mark_NL New Member

    I think you need to install the dev package as well

    It's called "libstdc++devel" on fedora (i think)
  5. delgado2061

    delgado2061 New Member

    no fedora package libstdc++devel or libstdc++-devel
  6. delgado2061

    delgado2061 New Member

    the devel package is also install already. by looking on the first picture of this I don't have the subdirectory /ld I have /usr/bin but no ld subdirectory so the compile have to be looking on the wrong place.

    Last edited: Jun 7, 2010
  7. Mark_NL

    Mark_NL New Member ;-)

    ld is a linker, anyway .. i think you need to specify WHERE the libstdc files are .. maybe it's not on a place where clamav expects them to be .. check the ./configure --help command for that.
  8. delgado2061

    delgado2061 New Member

    What I don't understand? I been updating from way back to version 2.2.24, 25, 26, 27 , 28, 29 , 30, 31, 32, 33, 34, to 2.2.35 clamav is in the same place for all other version. why this update is diferent with clamav. all other version had no problem installing the clamav on my ispconfig server .
  9. Mark_NL

    Mark_NL New Member

    Same here, until some day clamav stopped working because the databases the update mirrors supplied where in a different layout, which resulted in everyone needed to update theire clamav core files. Whet i mean to say with this is that stuff can work for years and suddenly stop working.. ;)

    Besides the fact that the installer should work, it's also very much suggested you start using ispconfig3 .. i've been running 2 for a long time and didn't want to switch, but i've migrated a few servers now and i can say i'm never going back to ispconfig2 .. with 3 i have way more control over what software i'm running (at least for me it's way cleaner then 2) ..

    oke, all things aside, the installer can't find libstdc that's a fact, when the compiler is called with -lstdc++ it will start looking for the lib files it needs in the most common locations like /usr/lib/, /lib or /usr/local/lib .. if it can't find them you'll see the error you get. It's possible that those files are in a different location and you need to specify where those files are so the compiler can find them.

    For libs you can use: LDFLAGS=-L<dir> ./configure ... <etc>
    For header files (includes): CFLAGS=-I<dir>

    So ehm, check and see if you have a file called* somehwere in:
    /usr/lib, /lib or /usr/local/lib

Share This Page