ispconfig - external mailserver

Discussion in 'Feature Requests' started by martinfst, Oct 14, 2008.

  1. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Could it be I found a bug?

    I modified an entry / domain in ispconfig to use an external mailserver (ispsite / options / external mailserver). Unfortunately, the entry in the postfix configuration file /etc/postfix/local-host-names is not removed. Even worse, when modifying the second domain, the 1st domain returns in local-host-names. I have to remove these entries manual (and restart/reload postfix).

    I expect by using an external mail server, the local-host-names would not contain these domains?
  2. iverson0881

    iverson0881 New Member

    Yeah I seem to have the same problem where my domain that is selected as an external mailserver does not remove entries from /etc/postfix/local-host-names.

    Is this a bug or is there a better way of getting this done??
  3. falko

    falko Super Moderator ISPConfig Developer

    That's right. Did you select "External Mailserver" also for the Co-Domains (it has to be selected individually for each domain/subdomain that you don't want to see listed in /etc/postfix/local-host-names - remember that is different from
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    I do have a co-domain, but I don't see the option to specify an external mailserver per (co-)domain. There is only one place to set this. :confused:
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    No, there is one place for the website and one for ecah co-domain. The co-domain has a external mailserver setting on the options tab in the co-domain form!
  6. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    That's it. You will have to click on the link of the co-domain and then you get a new screen, Such genius !:cool:

Share This Page