ISPConfig : [error] an unknown filter was not added: PHP

Discussion in 'Installation/Configuration' started by smilem, Jan 15, 2008.

  1. smilem

    smilem New Member

    Found this error in my httpd log files:

    And found a site suggesting a solution here:
    http://vanderkussen.org/index.php?/...rror-an-unknown-filter-was-not-added-PHP.html

    Tried it did not work? Need help

    I did not understand where should I change
    You should use

    AddType application/x-httpd-php .php

    And not


    SetOutputFilter PHP
    SetInputFilter PHP

    My /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf
    Code:
    <VirtualHost 192.168.1.11:80>
    ServerName www.mydomain.net:80
    ServerAdmin webmaster@mydomain.net
    DocumentRoot /var/www/web1/web
    ServerAlias mydomain.net
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
    
     
    Last edited: Jan 15, 2008
  2. edge

    edge Active Member Moderator

  3. smilem

    smilem New Member

    I changed the code from:

    change the line from:

    $go_info["server"]["apache2_php"] = 'both'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)

    to:

    $go_info["server"]["apache2_php"] = 'addtype'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)

    in the file /home/admispconfig/ispconfig/lib/config.inc.php

    Now it seems to work, I read that:

    Code:
    After you changed this line, you must modify a avlue in one of your websites to let ISPConfig rewrite your configuration files.
    What line of code?
     
  4. edge

    edge Active Member Moderator

    Change some setting in ISPconfig to let it re-read / load the changed /home/admispconfig/ispconfig/lib/config.inc.php file
    Any change should do the trick, but I normally make a small change to one of the DNS'ses (ISPconfig > DNS manager), to force ISPconfig to re-read / load a changed file.
     
    Last edited: Jan 16, 2008
  5. smilem

    smilem New Member

    Thanks, I applied some apache directives and error stopped.
     
  6. tensor

    tensor New Member

Share This Page