ISPConfig - email piping to osticket

Discussion in 'General' started by ichpen, Jan 2, 2012.

  1. ichpen

    ichpen New Member

    Hoping someone here can help.

    Running ubuntu 11.10 and latest ispconfig 3.

    I have a mailbox [email protected] that will be used for email piping.

    I'm trying to get the osticket WP plugin working with email piping but no joy. I've run through many posts and tried the following:

    Custom email filter recipe: to "|/var/www/clients/client4/web4/web/wp-content/plugins/zingiri-tickets/osticket/upload/api/pipe.php"

    This produces a rather hard to catch error in the mail.log vmail[5000] no recipient found in header ....

    I've tried creating a system user helpdesk, then adding a new alias
    helpdesk: "|/var/www/clients/client4/web4/web/wp-content/plugins/zingiri-tickets/osticket/upload/api/pipe.php"

    Then using cc "!helpdesk@localdomain" in custom rules (ispconfig).

    This actually gave me a proper message after an error as below:

    Jan 2 11:07:19 server1 postfix/sendmail[15166]: fatal: nobody(65534): No recipient addresses found in message header

    Jan 2 11:07:19 server1 postfix/local[15162]: 189A615A1F65: to=<helpdesk@localhost>, relay=local, delay=0.08, delays=0.02/0.01/0/0.05, dsn=2.0.0, status=sent (delivered to command: /var/www/clients/client4/web4/web/wp-content/plugins/zingiri-tickets/osticket/upload/api/pipe.php)

    But again, no ticket is created in osticket. No other errors in syslog or mail.log.

    Using redirect "helpdesk@localhost" also produces same result as above.

    At a loss here and would appreciate any suggestions.
    Last edited: Jan 2, 2012

Share This Page