ISPConfig e-mail problems

Discussion in 'Installation/Configuration' started by mr_bo, Sep 28, 2008.

  1. mr_bo

    mr_bo New Member

    Hi,

    Can someone please help.

    I have a new install of ispc on Ubuntu and all works well except for receiving mail. I have configured outlook express and read up loads on here and the net but still scratching my head.
    I can send/receive ok in oe with no errors and send mail ok but cannot receive mail.

    Thanks in advance.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which errors appear in the mail log when you send a email to your account?
     
  3. mr_bo

    mr_bo New Member

    I'm looking at /var/log/mail.log and this is what I see after I hit send/receive in oe:

    Code:
    time=0
    Sep 29 19:27:42 server pop3d: Connection, ip=[::ffff:192.168.0.1]
    Sep 29 19:27:42 server pop3d: LOGIN, user=web1_admin, ip=[::ffff:192.168.0.1], port=[4126]
    Sep 29 19:27:42 server pop3d: LOGOUT, user=web1_admin, ip=[::ffff:192.168.0.1], port=[4126], top=0, retr=0, rcvd=12, sent=39, time=0
    
    and this is from when I tried to send a mail to my work address:


    Code:
    Sep 29 09:47:21 server postfix/smtp[14904]: BA416E2382: host mail-xxx.xxxxx.com[xxx.xxx.xxx.xxx] refused to talk to me: 554 mail-xxx.xxxx.com
    Sep 29 09:47:21 server postfix/smtp[14904]: BA416E2382: host mail-xxx.xxxx.com[xxx.xxx.xxx.xxx] refused to talk to me: 554 mail-xxx.xxxx.com
    Sep 29 09:47:21 server postfix/smtp[14904]: BA416E2382: to=<[email protected]>, relay=mail-xxx.xxxx.com[xxx.xxx.xxx.xxx]:25, delay=2.1, delays=0.1/0.04/2/0, dsn=4.0.0, status=deferred (host mail-xxx.xxxx.com[xxx.xxx.xxx.xxx] refused to talk to me: 554 mail-xxx.xxxx.com)
    (had to edit ip's and server)
     
    Last edited: Sep 29, 2008
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you run your server on a dsl or kable line with a dynamic IP address?
     
  5. mr_bo

    mr_bo New Member

    Yes, it is currently on dsl with dynamic ip, for the next six weeks. Then I will be changing service provider to a static ip dsl service.
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. mr_bo

    mr_bo New Member

    Ta for that, will check it out when i get home.

    If so, can I be removed?


    Here is the results:

    Code:
     	
    Blacklist Name	 	Status	Reason	TTL	Response Time (ms)
    CASA-CBL+	Listed	LISTED	Mail from xx.xxx.xx.xxx refused, see Detail
    Return codes were: 127.0.8.6	9595	641
    CASA-CDL	Listed	LISTED	Mail from xx.xxx.xx.xxx  refused, see Detail
    Return codes were: 127.0.8.4	9595	641
    Spamhaus-ZEN	Listed	LISTED	Detail
    Return codes were: 127.0.0.10	595	3797
    
    <snip>
    
    CSMA	Listed	TIMEOUT	Return codes were: ERROR, Reponse code=2 	0	0
    HILLI	Listed	TIMEOUT	Return codes were: ERROR, Reponse code=2 	0	0
    INFORMATIONWAVE	Listed	TIMEOUT	 	0	0
    NJABLDYNA	Listed	TIMEOUT	 	0	0
    SOLID	Listed	TIMEOUT	Return codes were: ERROR, Reponse code=2 	0	0
    SPEWS1	Listed	TIMEOUT	 	0	0
    TQMCUBE	Listed	TIMEOUT	 	0	0
    
    
    
     
    Last edited: Sep 30, 2008
  8. JeGr

    JeGr Member

    Most likely the receiving SMTP server runs some sort of RBL checks and perhaps another on known dialup lines. If so, even unlisting your ip wouldn't change much, as your IP can be traced down to be a dialup one and will sometimes be blocked.
    I don't think you will be able to "unlist" the ip as you'll get another one after a reconnect with your ISP and the play starts again.
     
  9. falko

    falko Super Moderator ISPConfig Developer

  10. mr_bo

    mr_bo New Member

    Thanks for all your help.

    I already pay a company to host my sites for me and I wanted to get away and host myself, but my current isp is obviously the problem, so I have shifted everything back to the hosting company for now as in 2 weeks I will obtain my mac code and move to a better isp with a static ip service that does not block port 25 and then shift everything back to my linux box here. :)
     
  11. mr_bo

    mr_bo New Member

    Hello again, I'm back..

    I have now switched to an isp with static ip and all is ok on that side.

    But now I can send mails ok using outlook express, but get
    Code:
    This message was created automatically by mail delivery software.
    
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:
    
      [email protected]
        No Such User Here
    
    when I send a mail to the account on isp config.

    Thanks for any help in advance.
     
  12. falko

    falko Super Moderator ISPConfig Developer

  13. mr_bo

    mr_bo New Member

  14. falko

    falko Super Moderator ISPConfig Developer

  15. mr_bo

    mr_bo New Member

    It is exact, and to be sure I also added it manually.

    If I send a mail from a web based e-mail, google, the mail delivers ok and drops into my inbox on outlook express, but if I use another mail account which is on the server I am currently renting then it gets sent back with the error.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Can you check if the MX record for xxxxxxx.co.uk is correct?
    Code:
    dig mx xxxxxxx.co.uk
     
  17. mr_bo

    mr_bo New Member

    I have an A record for mail.xxxxxx.co.uk and all mails seem to be getting through except from the server I rent.

    I will be giving up that server when I get this sorted and moving everything to my ispc server.

    I think it is safe to do so tonight and take a gamble as I think the ispc server is ok.
     
  18. mr_bo

    mr_bo New Member

    Hi, the ispc server has been up and running for a little over a week with no mail problems.
    Thanks for your help, I have learnt alot from here. :)
     

Share This Page