ISPConfig + Drupal Multisite

Discussion in 'Installation/Configuration' started by Felipe, Sep 3, 2007.

  1. Felipe

    Felipe New Member

    Hello.

    I'd like to know if somebody has a guide on how to install a Drupal Multisite under a running ISPConfig. I've found one link [1] for Drupal multisite installation on howtoforge but it is not using ISPConfig, i tried to adapt the paths but something is going wrong.

    Any information is welcomed.

    [1] http://www.howtoforge.com/multisite_drupal_installation_ubuntu

    Thanks,
    __________
     
  2. BioALIEN

    BioALIEN New Member

    I'm also after this. I managed to get Drupal working with one installation having followed all the tutorials but it would be great to find out how to organise a multisite setup using ispConfig.
     
  3. falko

    falko Super Moderator

    What exactly isn't working? Do you have any error messages?
     
  4. Felipe

    Felipe New Member

    Hi falko

    Once it is a published web site, I had to come back all the confs, tonight I'll try again and I'll post the error message here.

    Until where I remember, when accessing the page to configure drupal, it was showing an error related with permission. This access is to configure the #1 drupal website.

    thanks for your time.
     
  5. Felipe

    Felipe New Member

    Hello, I'm back...

    I'll post the step-by-step of what I did, I've used the following link as a reference:

    http://www.howtoforge.com/multisite_drupal_installation_ubuntu

    Starting...

    -> Configure DNS - not needed.

    -> Install Packages - they are there.

    -> Test Apache2/PHP Installation
    On ISPConfig I've selected the websites I'm working on and have selected the option 'PHP Scripts' but not 'PHP Safe Mode' under 'Basic' tab. After this, my websites were able to run PHP scripts.

    -> Test MySQL Installation - ok

    -> Install Drupal Using CVS - ok

    -> CVS Updates - ok

    -> Create Additional Directories - ok

    -> Create the Drupal Sites - now start the problem. I'm in doubt about this step because I really don't know if this step is needed, if is needed to do it to enable the websites to be reached. I'm using ISPConfig and on my point of view, it is an unnecessary step, off course, with the exception for the mysql stuff, anyway, I made it :)
    cd /var/www/drupal/sites
    cp -a default www.example-a.com
    cp -a default www.example-b.com
    To create mysql user and dbs I've used ISPConfig. To run the 'grant' command I've used phpmyadmin.
    At this instructions: "We now need to configure Apache to serve up the two websites. The first step is to allow multiple websites on the same server (virtual websites):" I made like showed.
    I've edited the file /etc/apache2/sites-available/default like showed and then, using this template I've issued the following commands:
    cd /etc/apache2/sites-available
    cp default www.example-a.com
    cp default www.example-b.com
    cd ../sites-enabled
    rm 000-default
    ln -s ../sites-available/www.example-a.com 001-www.example-a.com
    ln -s ../sites-available/www.example-b.com 002-www.example-b.com

    The difference here is the sites names, at the link, the names are only 'www' and 'www2' in my situation I informed the full website URL and when I've restart apache it is happening an error like this:

    server:/etc/apache2/sites-enabled# /etc/init.d/apache2 restart
    Forcing reload of web server (apache2)... waiting Syntax error on line 6 of /etc/apache2/sites-enabled/001-www.example-a.com:
    AllowOverride not allowed here
    failed!

    -> Configuring Drupal - first, I need to correct the error and then I'll be able to walk here...

    falko or *, this message helps you on helping me or you need more information? if 'yes', please let me know.

    thanks,
     
  6. falko

    falko Super Moderator

    You don't have to do this because you have ISPConfig to create web sites...
     
  7. Felipe

    Felipe New Member

    Ok falko, I will skip this step, now, what is the best way to point the ISPConfig website to access the Drupal website.

    Should I edit the file /etc/apache2/vhosts/Vhosts_ispconfig.conf and set the 'DocumentRoot' pointing to '/var/www/drupal/www.example-a.com' or should I add the following <Directory> tag in the Apache Directives field on the 'Basis' tab.

    <Directory /var/www/drupal/www.example-a.com/>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    I've got this <Directory> tag from this link http://www.howtoforge.com/drupal_ispconfig

    Other question is should I create the '.htaccess' file inside the Drupal website? if yes, what should be in this file?
     
  8. Felipe

    Felipe New Member

    Some Help with '500 error - Internal Server Error!'

    This error is happening when I'm trying to access the url 'www.example-a.com'

    At this file '/var/www/web2/log/error.log' we have a lot of this message:

    [Mon Sep 10 11:56:01 2007] [alert] [client 192.168.1.6] /var/www/drupal/.htaccess: Option Indexes not allowed here

    Now, what I've made to try to solve this issue.

    Changed the tag for 'mod_rewrite.c' on '/var/www/drupal/.htaccess' to:

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA] ### -> added the '/' before 'index.php'
    </IfModule>

    Modified the 'AllowOverride' and commented the <Files> tag at the /etc/apache2/apache2.conf, it now look like this:

    <Directory /var/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    #AllowOverride None
    AllowOverride All
    #AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    #<Files ~ "^\.ht">
    #Deny from all
    #</Files>
    </Directory>

    On '/etc/apache2/vhosts/Vhosts_ispconfig.conf' file, the 'DocumentRoot' is pointing to '/var/www/drupal/www.example-a.com'.
    Changed the group and owner of the directory '/var/www/drupal/sites/www.example-a.com' to 'www-data' and 'web2'

    For this Vhost at the file '/etc/apache2/vhosts/Vhosts_ispconfig.conf' the configuration look like this:

    ######################################
    # Vhost: www.example-a.com:80
    ######################################
    #
    #
    <VirtualHost 111.111.111.111:80>
    ServerName www.example-a.com:80
    ServerAdmin webmaster@www.example-a.com
    #DocumentRoot /var/www/web2/web
    DocumentRoot /var/www/drupal/sites/www.example-a.com
    ServerAlias www.example-a.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index
    .pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web2/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    Alias /error/ "/var/www/web2/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    </VirtualHost>

    Well, I'm really needing your help to solve this issue because I don't know what could be the next step to put ISPConfig + Drupal Multisite running together here on my server.

    Thanks in advance,
     
  9. ashishpadave

    ashishpadave New Member

    Any solution here?
     

Share This Page