ISPConfig Dovecot v1.2.14

Discussion in 'Installation/Configuration' started by AVG, Sep 10, 2010.

  1. AVG

    AVG Member

    Hello!!!
    Friends tell me please what is wrong?
    I have configured ISP3 with CentOS 5.4
    When i login with RoundCube to my mail server i have an error
    Log from Dovecot

    Sep 11 00:34:14 xhost dovecot: IMAP([email protected]): mail_location: Ambiguous mail location setting, don't know what to do with it: /var/vmail/xhost.lv/avg/Maildir (try prefixing it with mbox: or maildir:)
    Sep 11 00:34:14 xhost dovecot: IMAP([email protected]): Fatal: Namespace initialization failed

    but in my dovecot config file i think its all right
    mail_location = maildir: /var/vmail/%d/%n/Maildir

    What can be wrong???

    Sorry for my english...
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please try
    Code:
    mail_location = maildir:/var/vmail/%d/%n/Maildir
    (no space after maildir: ) instead of
    Code:
    mail_location = maildir: /var/vmail/%d/%n/Maildir
     
  3. AVG

    AVG Member

    thanks for the reply
    'm sorry the previous post, I accidentally printed with a space.
    In fact, in the config Dovecot without space
    mail_location = maildir:/var/vmail/%d/%n/Maildir

    what else could be the problem?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Dovecot is reading this path from the mysql database, a mail_location should not be nescessary in the dovect file. Try to comment it out and restart dovecot.
     
  5. AVG

    AVG Member

    Thanks for your reply.
    Try the commented out line as you advised, but the result is the same:
    dovecot: IMAP([email protected]): mail_location: Ambiguous mail location setting, don't know what to do with it: /var/vmail/xhost.lv/avg/Maildir (try prefixing it with mbox: or maildir:)
    dovecot: IMAP([email protected]): Fatal: Namespace initialization failed
     
  6. AVG

    AVG Member

    Thank you all for your advice!

    I found what was the problem.
    When i install the ISPconfig, ISPconfig has created user "vmail" which is an owner of dir /var/vmail/ with UID and GID
    587, but in the panel there was UID and GID 5000 for the user "vmail", i have changed UID and GID for the user "vmail" to 5000 and thats all.
    now it works perfectly.

    I hope this helps to someone.
     

Share This Page