ISPConfig don't work with my server

Discussion in 'Installation/Configuration' started by catalyst, Apr 3, 2007.

  1. catalyst

    catalyst New Member

    I installed a Fedora 6 and ISPConfig to my server, this was working properly.

    However, I tried to install Ubuntu 6.10 & ISPConfig later, during the installation process, there was no error.
    But after that, I used a PC to open the ISPConfig on my browser, I couldn't access ISPConfig because I couldn't open the web page. (https://myserver.domain.com:81)

    My Server is Core2 Duo 6300 with Intel 965 chipset motherboard.
    What happen to my server?
    Do you have any idea about this?
    Thank you!
     
  2. mlz

    mlz New Member

    If your getting an SSL certificate mismatch, you need to clear out the old certificate from your browser.
     
  3. birumerah

    birumerah New Member

    check if you browser disable meta redirect :)
     
  4. catalyst

    catalyst New Member

    It is not related to my browser or client side. (I have used 2 pcs both IE & Firefox to open it)
    The problem is the back end side (server side).
    I have tried to type https://192.168.0.2 (my server's ip, testing the SSL only), but it also doesn't work. The ssl is not function.
    But when I install the ssl module at the server side, there is no error. I have already tried to re-install the server 3 times. And the SSL still doesn't work. (I have tried to use another PC to test it too).
    Now, I am going to install ISPConfig without SSL and see whether the ISPConfig will work or not!

    I am using AMD 64 bit ISO on my Intel Core2 Duo 6300 server. Can I install AMD 64bit ISO on Intel sever? (But I can't find an ISO for Intel 64bits CPU on Ubuntu website).
     
    Last edited: Apr 4, 2007
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You must use https://192.168.0.2:81 and not https://192.168.0.2, the :81 is absolutely nescessary to connect to the controlpanel! Please try to access the page with firefox in case you used IE before, firefox gives better SSL error messages in case your SSL-Cert is corrupted.

    Please post the output of:

    netstat -tap

    and:

    iptables -L

    A reinstallation is most liekly not nescessary.
     
  6. catalyst

    catalyst New Member

    Oh! God! Who can help me? What's happen to the installation of the Linux OS!

    At the very beginning, I install Fedora 6 on Intel Core2 Due Server, then I can't run ISPConfig with HTTP://, but I can only run ISPConfig with HTTPS://

    Now, I install Ubuntu to the Intel Core 2 Duo Server, I can't run ISPconfig with HTTPS://, but can run it with HTTP:// (I install it on AMD 3200+ without this problem)
    Installation of ISPConfig with or without HTTPS are all OK! It is the problem of SSL.
    But when I login ISPConfig, I can create SSL for first website. For the second website, there is a warning message say SSL cert. are already created. But other website can use SSL too. Becuase they are in the same IP.
    I can open https://www.mywebsite.com in my browser.

    So that I can only open http://www.mywebsite.com:81 to run the ISPConfig on my Intel Core 2 Duo Server
     
    Last edited: Apr 4, 2007
  7. catalyst

    catalyst New Member

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 4939/mysqld
    tcp 0 0 *:81 *:* LISTEN 7426/ispconfig_http
    tcp 0 0 ns1.myserver.com:domain *:* LISTEN 7672/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 7672/named
    tcp 0 0 *:smtp *:* LISTEN 8358/master
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 7672/named
    tcp6 0 0 *:imaps *:* LISTEN 3815/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 3848/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 3827/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 3796/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 8845/apache2
    tcp6 0 0 *:ftp *:* LISTEN 8077/proftpd: (acce
    tcp6 0 0 *:ssh *:* LISTEN 3950/sshd
    tcp6 0 0 *:smtp *:* LISTEN 8358/master
    tcp6 0 0 ns1.myserver.com:953 *:* LISTEN 7672/named
    tcp6 0 0 *:https *:* LISTEN 8845/apache2
    tcp6 0 592 ns1.myserver.com:ssh ::ffff:192.168.1.1:1613 ESTABLISHED4580/1

    ===================
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    root@ns1:~/install_ispconfig#
     
  8. catalyst

    catalyst New Member

    Hi Till
    I follow all the perfect installation of Linux in these website.
    Do you have any idea about the SSL problems. It is confusing!
    Including the installation of Fedora 6, Ubuntu and SUPHP on both OS, I have installed all the System more than 10 times.........

    Besides, I am still looking for the tutorial on the installation of suPHP on the Perfect setup of fedora 6.
    If anyone have installed suPHP successfully on Fedora, please post your tutorial on this website please.

    Many Thanks!
     
    Last edited: Apr 4, 2007
  9. i.am.dark

    i.am.dark New Member

    i think u must read the Manual Carefully
    http://www.ispconfig.org/manual_installation.htm
    Code:
    Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system: 
    
    If you want to use your control panel with SSL, 
    
    Select 1. You can then access it under https://www.xyz.de:81. 
    
    Select 2If you want to access it under http://www.xyz.de:81, 
     
  10. catalyst

    catalyst New Member

    Yes! I have already selected 1. HTTPS or 2. HTTP. If not, I can't continue to install the ISPConfig.
    But I select 1., after installation, I can't access ISPConfig both of HTTPS:81 or HTTP:81. (because ISPConfig is set to HTTPS)
    If I select 2, Yes. I can access it with HTTP:81

    The main reason of this matter is I can't access the SSL even before the installation of ISPConfig. (Fedora 6 is OK, but ISPConfig must installation on HTTPS, if I select HTTP, I can't access it. Besides, I install Ubuntu on my AMD server, I can select HTTPS and access it.)
    But after I login ISPConfig (HTTP:81), I can activate the SSL cert. for the first website. For the second website, it can share the SSL of the first website (share IP). It seems that SSL is also no problem.

    So that the main point is why I can't access SSL before the installation of ISPConfig. But I am following the Perfect installation of Ubuntu 6.10 on this website and there is no error when I am installing the server.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    What is your problem? You can never access anything before it is there. So you can not access ISPConfig on port 81 before you install ISPConfig. I think thats a question of general logic.

    Above you tell us, that you can not login to ISPConfig and here you tell us, that you have created a website in ISPConfig. How can you crete websites in ISPConfig if you are not able to login...
     
  12. catalyst

    catalyst New Member

    Sorry! You misunderstand my meaning. I mean that I can't access SSL page by tying https://www.mywebsite.com/ in my browse. It seems that the SSL is no activated. (I have already install the openssl in my server).
    This testing is doing at my 3rd times install of the Ubuntu. I just want to test it whether I can access the SSL or not before I go to install the ISPConfig.

    Sorry for my poor English, it make you misunderstand my problem again. In fact, I can install the ISPConfig to my server. But I choose 1. HTTPS during the installation of ISPConfig, I can't access & login ISPConfig if I install ISPConfig on HTTPS.
    If I choose 2. HTTP during the installation of ISPConfig, I can access & login ISPConfig.
    This is the problem. I should clarify that I can install ISPConfig but can't access it if I install it on HTTPS.
    Why I can create a website in ISPConfig? Because I choose to install it on HTTP.

    Besides, for the Fedora 6, I must choose to install ISPConfig on HTTPS, if I install it on HTTP, I can't access & login ISPConfig too.
    This is quite strange!
     
    Last edited: Apr 5, 2007
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    First, it does not matter if you access ISPConfig by http or https if you want to create a SSL based website, so please dont mix this up.

    If your server is in a NAT enviroment behind a router, please make sure that you open port 443. Did you follow one of the perfect setup howtos to install your server?

    Please post the output of:

    netstat -tap

    and

    iptables -L
     
  14. catalyst

    catalyst New Member

    Yes! port 443 was opened in my router. Firewall in Linux was disabled.
    I follow all the Perfect setup of Ubuntu 6.10 and Fedora 6.
    I am sure that during the installation of Linux OS, there is no error or mistake generated by me. Because I have installed the Linux OS more that 10 times after I find the problems of setting up ISPConfig & suPHP. Because I don't know how to solve it. So I would like to clarify it there is no error during my installation of the Linux & ISPConfig.
     
    Last edited: Apr 5, 2007

Share This Page