ISPconfig doesn't work after restart

Discussion in 'Installation/Configuration' started by Upyr, Oct 29, 2007.

  1. Upyr

    Upyr New Member

    Hello Guys:

    I installed ISPconfig following the openSUSE 10.3 HOW-TO , everything seemed to work fine after the installation, I opened ISPconfig with and it worked, I didn't change anything inside the control panel. The problem is that now, after restarting the system I can't get to ISPconfig.

    Any ideas?

    Thanks in advance
  2. finity

    finity New Member

    Try this in an terminal window

    chkconfig --add ispconfig-server
    /etc/init.d/ispconfig-server start

    Hope this helps

  3. Upyr

    Upyr New Member


    Thanks for the help, I ran the init script and it works fine, my problem is that I Encrypted the keys in Step7 and Step8 of the ISPconfig installation so I can't automatically start the server. The good thing is that this is a test system (on my laptop actually) and not a production one, I will be more carefull when I install this for production.

  4. finity

    finity New Member

    Same thing happened to me ... so, glad I could help!

    Bye bye!

  5. Upyr

    Upyr New Member

    Now I got ISPconfig up and running.... I haven't been able to test it over the Internet with the domain names I have registered, so I cannot see if the pages are serving right yet.

    On the other side I test FTP in my local set-up and I can't log in through the Web-FTP it reads unable to connect as user "blah", but using a FTP client I can connect as Anonymous.... Any clue what this error is?

  6. finity

    finity New Member

    No, sorry ... I didn't get to that point.

    If I can't make BIND work in the local network I don't really care about the ftp.

    I was kind of disappointed when I tried the virtual appliances from ipsconfig site and in a simple scenario it just does not work. I run the iso image into vmware server, in a simple network with a rooter, added a reseller, a client and a site something like
    I was hopping to see some default page when accessing in the internal network.
    I also installed an openSUSE and ISPconfig control panel acording to the HowtoForge tutorial on this topic. All whent well ... but the same issue ... can't see the

    Did you manage to pass this step ?

  7. Upyr

    Upyr New Member

    Well, when I point to my loopback address I get a welcome message from ISPconfig telling me that the IP adress is shared... Since ISPconfig manages the sites as name based virtual hosts (or at least I whink it does :p) I can't try it. Fortunatelly I have 2 domains which I can use to make some tests, just let me check if it works as soon as I get home and I will tell you what I get. I think if the domains are all administered by an external DNS BIND doesn't have to be configured...

  8. falko

    falko Super Moderator ISPConfig Developer

  9. Upyr

    Upyr New Member

    Falko, thanks for the reply. I have the DNS record for both domains that will be hosted for now registered with dnsexit and at least the records seem to work when I ping from the outside. Right now I'm not home so I can't really test the configuration. I will do it tonight or this afternoon and post the outcome here to see if it helps others.

    Thanks again
  10. Upyr

    Upyr New Member

    I did it!!!!!

    I tried again putting my ISPconfig box in the DMZ and now it seems to be working fine. When I try to access my sites by domain name I get the default index ISPconfig sets up for me. Now I just have to try the mail system. I asked a friend of mine to send an e-mail to my dummy account and he hasn't got a response from the mailer daemon now. The only thing is I dunno how to configure my mail client to retrieve the mail or even to test if i got it. On the other side, i'm planning on installing a web mail and I found two suggestions on the ISPconfig site: Squirrelmail and RoundCube. Any suggestions on which one is better?

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Both are great applications. I recommend to install both and see which one is your personal favorite.

Share This Page