IspConfig doesn't update the server by the Do OSUpdate

Discussion in 'Installation/Configuration' started by vaio1, Dec 23, 2015.

  1. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Hi guys,
    the ISPConfig doesn't update the server when I try to use the automatic update feature under:
    System > Remote Action > Do-OSUpdate > All Servers
    How have I to solve this issue?
    thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use Debian or Ubuntu?
     
  3. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Hi Till!
    Debian OS
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The feature should work on Debian, at least I'am not aware of any issues in the current version. You can try to use the debug mode to see why it fails on your server.
     
  5. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    I have set the debug mode. This is the log:
     
  6. Dianaclau28

    Dianaclau28 New Member

    Hi till.
    I'm using Ubuntu 14.04 apache server .

    What does the ISPConfig action System > Remote Action > Do-OSUpdate > All Servers does?

    Why is it dangerous?

    Will i loose all my info from ISPConfig?

    Will my websites become unavailable?

    Thx!
     
  7. ztk.me

    ztk.me Active Member

    Depends on what's getting updated. Sometimes you also receive important messages if something critical has been changed or you'll be asked wether to keep a configuration file / overwrite it.

    You should see wether your websites or other services become N/A depending on the available updates.
    There is always a chance something can go wrong or needs your attention - it's always better and recommend to do them on your own. However it can be done and chances something goes wrong are usually very low :)
     

Share This Page