ISPConfig doesn't gracefully handle error conditions

Discussion in 'General' started by iandouglas, Oct 15, 2007.

  1. iandouglas

    iandouglas New Member

    Hey all,

    My biggest beef with ISPConfig is that it doesn't handle error conditions very well. Or delete users.

    I set up my FC7 box according to the "perfect server" instructions here at howtoforge.com, and created an SSL cert for my server1.example.com server. However, when I go into ISPConfig, and tried to add "example.com" as a site so I can actually get Emails and so on, it gave me an error that an SSL certificate already existed (SSL was an option I'd selected when setting up the site).

    So okay, fine, I'll add it again without the SSL option. Whoops, can't do that, it says that "example.com" is already used by another site, but "example.com" doesn't show up anywhere. So I'm stuck now -- I can't delete the domain because it doesn't list anywhere, and I can't re-add it.

    The same thing happens when deleting users -- ISPConfig doesn't actually delete the user. I added an administrative user for another domain, then changed my mind about the username, so deleted the user, but then could not create another administrative user because ISPConfig said the domain already had an admin user. So now I was really stuck -- my domain had an inoperative admin user account and I couldn't remove it.

    So how do I get around these errors? There's also no easy way to 'uninstall' ISPConfig to try to start all over. Without digging into the code to know which files it writes to, I have no idea what to edit to undo things to get back to a clean system to start all over.
     
  2. catdude

    catdude ISPConfig Developer

    After deleting entries (users, domain, hosts, etc) you need to go into the Recycle Bin and click on "Empty Recycle Bin".
     
  3. till

    till Super Moderator

    As catdude explained, the things you encountered are no errors at all, you just have to empty the recycle bin if you want to delete a item like a domain or mailuser permanently.
     
  4. mlz

    mlz New Member

    Well, technically they are errors, but user errors rather then system errors, and the system could be a bit more graceful in it's handling of these issues...
     
  5. mnewbegin

    mnewbegin New Member

    same errors

    I get the same errors. and i have emptied the recycle bin.


    Except I did go in and delete the folder that was there for the domain, with ssh.


    but not i try to re add the domain it says..


    The name www.truckmaine.com is already in use by another site or domain.


    i need to re-add this. Also I think i have setup them wrong.

    when it makes the

    A record and points it with 192.168.0.129 www

    is that correct.

    is it not supposed to actually have my outside IP there? and my domain name
     
  6. till

    till Super Moderator

    The inside IP is correct. You should never delete a domain folder on the shell manually, this might cause many problems with web and email for all sites on the server.

    Have a look at all recycle bin's, it is most likely still there in one of them. Then empty the recycle bin.
     
  7. mnewbegin

    mnewbegin New Member

    ok thanks

    ok thanks I didnt know there was more than 1 recycle bin.


    when my machine starts back up i will try it.


    for some reason my fedora 7 gui takes half an hour to start up.
    it froze first time i booted it.. then i restarted and it was fine.. now its doing it again.


    can i start this machine command line? from the boot options?
    instead of the gui
     
  8. till

    till Super Moderator

    Did you install fedora7 with gnome or kde gui?
     
  9. mnewbegin

    mnewbegin New Member

    both gnome and kde

    both knome and kde and i think its starting kde by default where do i change it.?

    i tried adding the

    noapic into my grub bootup, which from the fedora forums said should fix it.
     
  10. till

    till Super Moderator

    It is fine if you start kde. ISPconfig has just some problems with gdm (the gnome login manager).
     
  11. mnewbegin

    mnewbegin New Member

    problems

    well at the momment i cannot even start my KDE gui.

    the computer keeps at the icon and cursor for hours, i hit ctrl+alt+F1 and get a prompt and i have no network connection for some reason.


    So my server is worthless, it wont start fully, because my GUI is failing.

    i tried Ctrl + Alt+backspace, to kill it but then it starts all over again.

    i have tried setting my server to

    telinit 3, but that doesnt seem to help anything.


    then i change back to telinit 5 and it tries to start my kde again.


    Im using fedora 7 64bit on a Biostar K8M800


    1. How do i kill the x sesssion to just run command prompt.

    2. how do i change a different window manager.
    -if i get to prompt can I do a yum install switchdesk?

    3. how do i reinstall kde, or uninstall it so the machine boots.

    first time i turned it on it came on froze right after a clean install, then i restarted thought it might have just been accident, and it took 20 mins to start, but started.

    it went days without being logged out. I restarted after i installed ispconfig, then it doesnt seem to like to start kde again, i dont think it has anything to do with ispconfig.
     
    Last edited: Oct 19, 2007
  12. till

    till Super Moderator

  13. mnewbegin

    mnewbegin New Member

    ok

    by default KDE is starting already not gnome.


    Gnome has never really started on my machine. Just by having it installed but not using this would this mess it up?

    i cant do a yum remove gdm

    it gives me a could not retrieve mirror list <urlopen (101 'netowrk is unreachable'

    Error. cannot retrieve repository metadata (repomd.xml) for repository fedora.

    Please verify its path and try again.
     

Share This Page