ISPConfig doesn't create new Vhosts

Discussion in 'Installation/Configuration' started by steven_twente, Oct 2, 2006.

  1. steven_twente

    steven_twente New Member

    Hi all,

    Unfortuntely I've ran into a problem creating new webs in ISPConfig. I've succesfully added one site to ISPConfig which is running great, but when I try to add another web I always get the "This IP is shared" page. I believe this is due to the fact that ISPConfig doesn't seem to create new vhosts in the Vhosts_ispconfig.conf file. If I read the contents of that file I only find the data for my first web. Do you guys have any idea how I can fix this?

    Thanks in advance!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Are there other copies of the file Vhosts_ispconfig.conf in the same directory with the date appended in the name?
  3. steven_twente

    steven_twente New Member

    Yes, there are indeed. I read in another post that ISPConfig does this when apache could not be restarted with the current settings right? How can I figure out what's wrong with my settings?


    The strange thing is; if I now change anything (like Co-domains) for that new web, it doesn't create a new Vhosts_ispconfig.conf with the date appended. So it looks as if the settings are ok now, but when I look at the Vhosts_ispconfig.conf file (witout date appended) I don't see any trace of the new web's settings.
    Last edited: Oct 2, 2006
  4. tom

    tom Member

    To check the apache2 syntax run:

  5. steven_twente

    steven_twente New Member

    It says the syntax is OK. This is weird. Should I try to remove the 2nd web entirely and start over again?
  6. steven_twente

    steven_twente New Member

    I tried to solve this problem by removing the new web, then creating it again. That resulted in the fact that ISPConfig was creating Vhosts files with date appended so I copied the one without a date to a backup file and copied the newest file (with date appended) to Vhosts_ispconfig.conf. Then I tried to restart Apache manually, hoping to see some errors. Luckily I got just a single error, stating that the SSL certificate of one of my webs could not be found. I still don't understand how the certificate dissappeared, but I created a new one and now the problem is solved. :D

Share This Page