ISPconfig doesn't change apache vhost conf file when using let's encrypt

Discussion in 'Installation/Configuration' started by ustoopia, Sep 8, 2016.

  1. ustoopia

    ustoopia New Member

    I used let's encrypt from the ispconfig 3 panel and for some sites it works, but not for all. I noticed that when I opened it gave me an ssl error that the certificate belongs to I did make that certicate for the subdomain but found it odd that the gave me that error. So first I checked of the cert files are located where they are supposed to be and if the symlinks are ok. Did not find any problems there. Then I looked at the apache vhost config file for and noticed that in comparrison to a working vhost config file it was missing the whole SSL part of the config. In other words the part that comes after <VirtualHost *:443>. The odd thing is, was the very first one I made and it did work for a short moment. When I noticed it was working I decided to create the certs for subdomain. Shortly after that the 1st stopped working. I could manually edit the vhost config file but my guess is that it will be overwritten by ispconfig if I ever need to change the setup for that domain in ispconfig. What would be best thing to do for me in this situation?
  2. ustoopia

    ustoopia New Member

    Ok ignore this topic or close it I already managed to fix it by changing some options in the panel and then saving it and after two tries it added the <VirtualHost *:443>. to the apache vhost conf file. A very acceptable workaround but perhaps something is a tiny bit bugged about this process??
    Oh and thanks for creating and maintaning ispconfig. Been a happy user for years now. And I'm really really loving the new admin panel layout and options. (3.1) . Good work, keep it up guys.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    No need to set this more than once, just wait until the creation of the cert is finished and ensure that the dns for the domain and all subdomains and alias domains points to the correct server.

Share This Page