ISPConfig does not compile on Ubuntulinux 6.06.1 PowerPC

Discussion in 'Installation/Configuration' started by tjm, Nov 9, 2006.

  1. tjm

    tjm New Member

    Just followed these instructions:

    But installing ISPConfig on an Apple PowerBook G3 Lombard (bronze keyboard, scsi & usb) by running ./setup breaks:

    Seems, that this is a platform related error (powerpc instead of i386/i686).

    Would be nice to see this fixed!

    Last edited: Nov 9, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont think that this is platform related. The installation stops beacuse you dont have the mysql dev package installed, which contains the header files to compile PHP with mysql.
  3. tjm

    tjm New Member

    ISPConfig PowerPC install Ubuntulinux 6.06.1 fixed but few probs left

    hii till

    thank you for the fast repsonse.

    did install what was missing. "mysql-dev" is not in the repositories but the packages above fill the gap of missing header files.

    afterwards installing ISPConfig went okay except of two issues:

    on ubuntulinux 6.06.1 proftpd's config files "prodftp.conf" and "modules.conf" are located at /etc/proftp/ instead of /etc/proftp.conf.​

    another issue is, that I can setup resellers, clients and webs, but the webfolders are placed into the servers root level, not into the folder "sharedip". it is possible to add webs but not to edit or delete them.

    they do not show up in the ISPConfig panels. in none of them.

    that's my web-server's root appearing when called by it's domain name (dynDNS). "web1" and "" are webs created by ISPConfig.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Create a symlink from /etc/proftp.conf to the current position of the proftpd.conf file. The problem is that Ubuntu claims to be a debian unstable but they changed the path of the configuration file to be incompatible with debian.

    After you deleted them, empty the recycle bin.

    Make sure that DNS A-Records exist for the domains pointing to your server.
  5. tjm

    tjm New Member

    ; <<>> DiG 9.2.2 <<>>
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24127
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ; IN A


    ;; Query time: 144 msec
    ;; SERVER:
    ;; WHEN: Thu Nov 9 19:12:17 2006
    ;; MSG SIZE rcvd: 45

    MacMini:~ tjm$

    the problem is, that they do not show up in ISPConfig after beeing created :eek: the server runs headless. get's admin-access via ssh only. deleting by using "sudo rm -fr <PATH>" should be sufficient, isnt' it?

    cheep tricks, dirty tricks. ;) if chosen "2) expert" as install option, the correct path may be altered within the configuring process.

    i am going to try a new install of ISPConfig. maybe it works on a second run.

    Last edited: Nov 9, 2006
  6. tjm

    tjm New Member

    90% success

    reinstalling solved the apache2 problem that had occured!

    but by a bad typo something went wrong with the proftp install section.

    now my proftp.conf files are a bit mixed up. here is the error message:
    i found a file named "proftp_ispconfig.conf" including these lines:

    # ISPConfig proftpd Configuration File
    #         Version 1.0
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    in /etc/ i have these folders and files:

    [email protected]:/var/www$ ls -lah /etc/proftp*
    -rw-r--r-- 1 root root   16 2006-11-09 18:04 /etc/proftpd.conf
    -rw-r--r-- 1 root root  309 2006-11-09 22:17 /etc/proftpd_ispconfig.conf
    -rw-r--r-- 1 root root  309 2006-11-09 22:17 /etc/proftpd_ispconfig.conf~
    total 12K
    drwxr-xr-x  2 root root 4,0K 2006-11-09 22:11 .
    drwxr-xr-x 81 root root 4,0K 2006-11-09 22:17 ..
    -rw-r--r--  1 root root   36 2006-11-09 22:11 proftp.conf
    total 20K
    drwxr-xr-x  2 root root 4,0K 2006-11-09 22:23 .
    drwxr-xr-x 81 root root 4,0K 2006-11-09 22:17 ..
    -rw-r--r--  1 root root  740 2006-11-08 21:49 modules.conf
    -rw-r--r--  1 root root 4,0K 2006-11-09 22:22 proftpd.conf
    [email protected]:/var/www$ 
    if i knew, what to paste in, where and to place all files on their dedicated locations and what files/dirs to remove, it would be possible to solve this last issue manually.

    will check for an existing thread. maybe someone remembers of a related one.

  7. tjm

    tjm New Member


    could fix most problems experienced.

    what's left is that ftp and web-ftp does not work for ISPConfig users but for local users it does.

    installing and checking emailservices and webmail is an open job too.

    thanks a lot for your support and this wonderful software!

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig users are local users. Please dont mix up the client and reseller login which dont have FTP access with the login for the (email) users which have FTP access when you check the FTP checkbox for the website.

    Email services (postfix / courier) must be installed and configured before you install ISPConfig, otherwise your configuration attempt may override settings from the ISPConfig installer.
  9. tjm

    tjm New Member

    UebaMail does not work, postfix does by webmin-usermin

    postfix is running fine and had been installed/configured prior to installing ISPConfig.

    receiving and sending mail using webmin-usermin works smoothly.

    on UebaMail login, if set to german, it tells

    in english this:
    looks a bit strange. what's the problem?

    mail is enabled for the ISPConfig-user!

  10. falko

    falko Super Moderator ISPConfig Developer

    First, you must send a mail to that user before you can log in for the first time. The mailbox is created when the first email arrives.
    Then make sure you use the correct username and password. For Uebimiau, you must use an email address instead of the username to log in:
  11. tjm

    tjm New Member

    That's exactly what I did. Sent a mail to [email protected] (Try out and I will send you a reply!)

    This mail had been delivered and was stored in "/var/mail/web_1_isp_kunde_1"

    The mail could be read by webmin-usermin logged in as "web_1_isp_kunde_1"

    Logging into UebaMail using "[email protected]" does not work. Logging into ISPConfig as this user works. Web-FTP works too.

    Just sent a new mail to the address and tried to access it by UebaMail before reading it in the webmin-usermin panel. Nothing changed.

    Might this be a conflict between webmin and ISPConfig? Both are based on proftp. Hmmm? Just a guess...
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please amke sure that yoe rellay enabled maildir under management > server > settings in ISPConfig and that the quota of the website and of the user is high enough to store the email. If you set the quota to 0, then the user wont get any emails.
  13. tjm

    tjm New Member

    Happy about your help!

    thank you Till for all your support. that did it. now all services are up and running smoothly!!!

    :) :) :)

Share This Page