ISPconfig do not work, after login logo+search box and blank page

Discussion in 'Installation/Configuration' started by gilas, Mar 31, 2022.

  1. gilas

    gilas Member

    Hi Till
    thank you for your help and great work. I'm using with success ISPConfig since several years. Now I have a problem: the ISPConfig interface is stucker.
    When I connect all is fine, I insert username and password, click the button to access and the result is a blank page where I can see only the logo (top-left) and the search box (top-right).
    Since today ISPConfig was running ok.
    It seems that is happened after installed PHP8.1+fpm, all was made following the tutorial:
    https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/
    The errrors showned by /var/log/apache2/error.log are the following (tail):

    [Thu Mar 31 12:14:28.566089 2022] [fcgid:warn] [pid 29961] [client 128.116.188.200:58102] mod_fcgid: stderr: #2 /usr/local/ispconfig/interface/web/index.php(117): tpl->pparse()
    [Thu Mar 31 12:14:28.566109 2022] [fcgid:warn] [pid 29961] [client 128.116.188.200:58102] mod_fcgid: stderr: #3 {main}
    [Thu Mar 31 12:14:28.566117 2022] [fcgid:warn] [pid 29961] [client 128.116.188.200:58102] mod_fcgid: stderr: thrown in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php(1366) : eval()'d code on line 116
    [Thu Mar 31 12:18:03.556948 2022] [fcgid:warn] [pid 29948] [client 128.116.188.200:58259] mod_fcgid: stderr: PHP Fatal error: Uncaught TypeError: count(): Argument #1 ($value) must be of type Countable|array, bool given in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php(1366) : eval()'d code:116
    [Thu Mar 31 12:18:03.557006 2022] [fcgid:warn] [pid 29948] [client 128.116.188.200:58259] mod_fcgid: stderr: Stack trace:
    [Thu Mar 31 12:18:03.557013 2022] [fcgid:warn] [pid 29948] [client 128.116.188.200:58259] mod_fcgid: stderr: #0 /usr/local/ispconfig/interface/lib/classes/tpl.inc.php(1366): eval()
    [Thu Mar 31 12:18:03.557019 2022] [fcgid:warn] [pid 29948] [client 128.116.188.200:58259] mod_fcgid: stderr: #1 /usr/local/ispconfig/interface/lib/classes/tpl.inc.php(769): tpl->_parse()
    [Thu Mar 31 12:18:03.557025 2022] [fcgid:warn] [pid 29948] [client 128.116.188.200:58259] mod_fcgid: stderr: #2 /usr/local/ispconfig/interface/web/index.php(117): tpl->pparse()
    [Thu Mar 31 12:18:03.557031 2022] [fcgid:warn] [pid 29948] [client 128.116.188.200:58259] mod_fcgid: stderr: #3 {main}
    [Thu Mar 31 12:18:03.557036 2022] [fcgid:warn] [pid 29948] [client 128.116.188.200:58259] mod_fcgid: stderr: thrown in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php(1366) : eval()'d code on line 116

    despite the configuration in /etc/apache2/sites-available/ispconfig.vhost:

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    <FilesMatch "\.php$">
    SetHandler fcgid-script
    </FilesMatch>
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Require all granted
    </Directory>
    IPCCommTimeout 7200
    MaxRequestLen 15728640
    </IfModule>

    and however inspecting the wrapper that's ok

    # more /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
    #!/bin/sh
    PHPRC=/etc/php/7.3/cgi/
    export PHPRC
    export PHP_FCGI_MAX_REQUESTS=5000
    export PHP_FCGI_CHILDREN=1
    exec /usr/bin/php-cgi \
    -d disable_classes= \
    -d disable_functions= \
    -d magic_quotes_gpc=off \
    -d open_basedir= \
    -d session.save_path=/usr/local/ispconfig/interface/temp

    I've reinstalled latest version but nothing is improving.
    I suspect that there is some misconfiguration and that ISPCONFIG is running with the latest PHP8.1-fpm instead a 7.3m as spected.
    Note that I have this daemons running
    ...
    php7.3-fpm
    php7.4-fpm
    ....

    and then PHP7.3 is up and running:

    ● php7.3-fpm.service - The PHP 7.3 FastCGI Process Manager
    Loaded: loaded (/lib/systemd/system/php7.3-fpm.service; enabled; vendor preset: enabled)
    Active: active (running) since Thu 2022-03-31 12:09:29 CEST; 1h 3min ago
    Docs: man:php-fpm7.3(8)
    Process: 28331 ExecStartPost=/usr/lib/php/php-fpm-socket-helper install /run/php/php-fpm.sock /etc/php/7.3/fpm/pool.d/www.conf 73 (code=exited, status=0/SUCCESS)
    Main PID: 28327 (php-fpm7.3)
    Status: "Processes active: 0, idle: 2, Requests: 0, slow: 0, Traffic: 0req/sec"
    Tasks: 3 (limit: 4697)
    Memory: 17.5M
    CGroup: /system.slice/php7.3-fpm.service
    ├─28327 php-fpm: master process (/etc/php/7.3/fpm/php-fpm.conf)
    ├─28329 php-fpm: pool www
    └─28330 php-fpm: pool www

    Mar 31 12:09:29 www.myserver.it systemd[1]: Starting The PHP 7.3 FastCGI Process Manager...
    Mar 31 12:09:29 www.myserver.it systemd[1]: Started The PHP 7.3 FastCGI Process Manager.

    thank you for your help
     
    Last edited: Mar 31, 2022
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. gilas

    gilas Member

    thanks, I read and changed using alternatives, without success.
    Here there is the out put of TEST (good idea!):

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Debian GNU/Linux 10 (buster)

    [INFO] uptime: 15:27:23 up 4 days, 23:06, 2 users, load average: 0.02, 0.03,
    0.00

    [INFO] memory:
    total used free shared buff/cache available
    Mem: 3.9Gi 2.2Gi 618Mi 99Mi 1.0Gi 1.3Gi
    Swap: 1.0Gi 96Mi 927Mi

    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.2.8p1


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 7.4.28
    [INFO] php-cgi (used for cgi php in default vhost!) is version 7.3.33

    ##### PORT CHECK #####

    [WARN] Port 21 (FTP server) seems NOT to be listening
    this is normal because I avoided to install FTP

    ##### MAIL SERVER CHECK #####
    this is normal because I avoided to a Mailer

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 1311)
    [INFO] I found the following mail server(s):
    Postfix (PID 29814)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 29857)
    [INFO] I found the following imap server(s):
    Dovecot (PID 29857)
    [WARN] I could not determine which ftp server is running.

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [anywhere]:995 (29857/dovecot)
    [localhost]:10023 (584/postgrey)
    [localhost]:10024 (29844/amavisd-new)
    [anywhere]:808 (663/VVAgent)
    [localhost]:10025 (29814/master)
    [localhost]:10026 (29844/amavisd-new)
    [localhost]:3306 (29580/mysqld)
    [localhost]:10027 (29814/master)
    [anywhere]:587 (29814/master)
    [localhost]:11211 (582/memcached)
    [anywhere]:110 (29857/dovecot)
    [anywhere]:143 (29857/dovecot)
    [anywhere]:465 (1946/smtpd)
    [anywhere]:22 (600/sshd)
    [anywhere]:25 (29814/master)
    [anywhere]:993 (29857/dovecot)
    *:*:*:*::*:995 (29857/dovecot)
    *:*:*:*::*:10023 (584/postgrey)
    *:*:*:*::*:10024 (29844/amavisd-new)
    *:*:*:*::*:10026 (29844/amavisd-new)
    *:*:*:*::*:587 (29814/master)
    [localhost]10 (29857/dovecot)
    [localhost]43 (29857/dovecot)
    *:*:*:*::*:8080 (1311/apache2)
    *:*:*:*::*:80 (1311/apache2)
    *:*:*:*::*:8081 (1311/apache2)
    *:*:*:*::*:465 (1946/smtpd)
    *:*:*:*::*:22 (600/sshd)
    *:*:*:*::*:25 (29814/master)
    *:*:*:*::*:443 (1311/apache2)
    *:*:*:*::*:993 (29857/dovecot)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    f2b-ssh tcp -- [anywhere]/0 [anywhere]/0 multiport dp
    orts 22
    f2b-postfix-sasl tcp -- [anywhere]/0 [anywhere]/0 multi
    port dports 25
    f2b-sshd tcp -- [anywhere]/0 [anywhere]/0 multiport dp
    orts 22

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain f2b-sshd (1 references)
    target prot opt source destination
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with ic
    mp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with ic
    mp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with
    icmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with ic
    mp-port-unreachable
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain f2b-postfix-sasl (1 references)
    target prot opt source destination
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain f2b-ssh (1 references)
    target prot opt source destination
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with ic
    mp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with ic
    mp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with i
    cmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with
    icmp-port-unreachable
    REJECT all -- ***.***.***.*** [anywhere]/0 reject-with ic
    mp-port-unreachable
    RETURN all -- [anywhere]/0 [anywhere]/0




    ##### LET'S ENCRYPT #####
    [WARN] You have both certbot and acme.sh installed. This can lead to problems.
    Certbot: /usr/bin/letsencrypt
    acme.sh: /root/.acme.sh/acme.sh

    [email protected]:/tmp# update-alternatives --config php
    There are 6 choices for the alternative php (providing /usr/bin/php).

    Selection Path Priority Status
    ------------------------------------------------------------
    0 /usr/bin/php8.1 81 auto mode
    1 /usr/bin/php5.6 56 manual mode
    2 /usr/bin/php7.2 72 manual mode
    3 /usr/bin/php7.3 73 manual mode
    * 4 /usr/bin/php7.4 74 manual mode
    5 /usr/bin/php8.0 80 manual mode
    6 /usr/bin/php8.1 81 manual mode

    Press <enter> to keep the current choice[*], or type selection number:
    [email protected]:/tmp# update-alternatives --config php-cgi
    There are 5 choices for the alternative php-cgi (providing /usr/bin/php-cgi).

    Selection Path Priority Status
    ------------------------------------------------------------
    0 /usr/bin/php-cgi8.1 81 auto mode
    1 /usr/bin/php-cgi5.6 56 manual mode
    2 /usr/bin/php-cgi7.2 72 manual mode
    * 3 /usr/bin/php-cgi7.3 73 manual mode
    4 /usr/bin/php-cgi7.4 74 manual mode
    5 /usr/bin/php-cgi8.1 81 manual mode

    Press <enter> to keep the current choice[*], or type selection number: q
    There are 5 choices for the alternative php-cgi (providing /usr/bin/php-cgi).
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    PHP version is wrong.
    Code:
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 7.4.28
    [INFO] php-cgi (used for cgi php in default vhost!) is version 7.3.33
    They should be the same and for Debian 10 default PHP is 7.3.
    If you have additional PHP versions installed, remember
    Code:
    update-alternatives --config php
    and
    Code:
    update-alternatives --config php-cgi
     
  5. gilas

    gilas Member

    fixed but again without success, see here:

    [email protected]:/tmp# update-alternatives --config php
    There are 6 choices for the alternative php (providing /usr/bin/php).

    Selection Path Priority Status
    ------------------------------------------------------------
    0 /usr/bin/php8.1 81 auto mode
    1 /usr/bin/php5.6 56 manual mode
    2 /usr/bin/php7.2 72 manual mode
    * 3 /usr/bin/php7.3 73 manual mode
    4 /usr/bin/php7.4 74 manual mode
    5 /usr/bin/php8.0 80 manual mode
    6 /usr/bin/php8.1 81 manual mode

    Press <enter> to keep the current choice[*], or type selection number:
    [email protected]:/tmp# update-alternatives --config php-cgi
    There are 5 choices for the alternative php-cgi (providing /usr/bin/php-cgi).

    Selection Path Priority Status
    ------------------------------------------------------------
    0 /usr/bin/php-cgi8.1 81 auto mode
    1 /usr/bin/php-cgi5.6 56 manual mode
    2 /usr/bin/php-cgi7.2 72 manual mode
    * 3 /usr/bin/php-cgi7.3 73 manual mode
    4 /usr/bin/php-cgi7.4 74 manual mode
    5 /usr/bin/php-cgi8.1 81 manual mode

    Press <enter> to keep the current choice[*], or type selection number:
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Rerun the commands to change the PHP version as shown in the post and then restart apache.
     
  7. gilas

    gilas Member

    more this is very annoying, infact this morning I configured 5 servers with the same procedure and only the last ISPConfig interface still broken. Here the output of the latest row of the generated HTML:

    <!-- Datalogstatus Modal -->
    <div id="datalogModal" class="modal fade" role="dialog">
    <div class="modal-dialog">
    <div class="modal-content">
    <div class="modal-header">
    <button type="button" class="close" data-dismiss="modal">&times;</button>
    <h4 class="modal-title">The following changes are not yet populated to all servers:</h4>
    </div>
    <div class="modal-body">
    <ul>

    remember that this happens just after made successfully LOGIN.
     
  8. gilas

    gilas Member

    ok received and resolved. Should restart apache!
    Forgive me for this (I'm stupid, fall in this after several years of work...)
    now I'm going to document this issue for the future

    thank you very much for your help!
     
    Th0m likes this.

Share This Page