ISPconfig didn't start when reboot

Discussion in 'Installation/Configuration' started by kong121s, May 15, 2006.

  1. kong121s

    kong121s New Member

    before I have this problem , I have e-mail problem which I can't send or receive mail.
    It sucessfully logs into my mailserver but whenever I try to send a message it says "Relay access denied."

    so, I tried to config hostname and DNS.
    But it doesn't work and make me this problem.
    I tried to config default value but it still have this problem T_T
    detail of my problem is :
    I must login to my server by putty and run /etc/init.d/ispconfig_server start by myself after reboot server. and then run /etc/init.d/proftpd start , /etc/init.d/sendmail start .

    Please help me. thank you :(

    and please answer this knowless question:
    How to see a boot time error log??
     
    Last edited: May 15, 2006
  2. kong121s

    kong121s New Member

    oh! I found an error that may be cause of my problem.

    I can't start postfix !!
    Where I can see logs of postfix?
     
  3. kong121s

    kong121s New Member

    sorry. It's my misunderstand about postfix.
    It can start but please look this

    Code:
    [root@www /]# /etc/init.d/postfix status
    master is stopped
    [root@www /]# /etc/init.d/postfix start
    Starting postfix:                                          [FAILED]
    [root@www /]# /etc/init.d/postfix restart
    Shutting down postfix:                                     [FAILED]
    Starting postfix:                                          [  OK  ]
    [root@www /]# /etc/init.d/postfix status
    master is stopped
    [root@www /]#
    
    !!!!
     
    Last edited: May 15, 2006
  4. falko

    falko Super Moderator

    What's in your mail log? The log is usually in /var/log.
     
  5. kong121s

    kong121s New Member

    This is a log (/var/log/maillog) when I login to webmail and send from web1 to web2

    Code:
    May 16 09:30:57 www postfix/postfix-script: starting the Postfix mail system
    May 16 09:30:57 www postfix/master[32482]: fatal: bind 0.0.0.0 port 25: Address already in use
    May 16 09:31:49 www dovecot: pop3-login: Login: user=<web1_test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    May 16 09:31:49 www dovecot: pop3(web1_test): Logout. top=0/0, retr=0/ del=0/0, size=0
    May 16 09:32:09 www sendmail[32659]: k4G2W9cK032659: from=<test@test.com>, size=480, class=0, nrcpts=1, msgid=<200605160232.k4G2W9cK032659@www.centorythailand.com>, proto=SMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
    May 16 09:32:09 www dovecot: pop3-login: Login: user=<web1_test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    May 16 09:32:09 www dovecot: pop3(web1_test): Logout. top=0/0, retr=0/ del=0/0, size=0
    May 16 09:32:09 www sendmail[32661]: k4G2W9cK032659: to=<webmaster@b4ninety.com>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=120480, relay=b4ninety.com. [###.##.##.##], dsn=4.0.0, stat=Deferred: Connection refused by b4ninety.com.
    May 16 09:32:19 www dovecot: pop3-login: Login: user=<web2_test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    May 16 09:32:19 www dovecot: pop3(web2_test): Logout. top=0/0, retr=0/ del=0/0, size=0
    
    There is something that I just found.
    It can't start postfix because sendmail is running. I must stop sendmail then I can start postfix as well.
    so, I redo "Postfix With SMTP-AUTH And TLS" in Perfect setup for fedora core 5.
    but It still not run ISPConfig after reboot.

    and... still can't receive any email from anyone.
    I can send mail from web2 to anywhere (except in my server).
    but I can't send mail from web1 which I didn't register it on worldwide (web2 is registered)
     
    Last edited: May 16, 2006
  6. till

    till Super Moderator

    With unregistered website you mean a fake domain like myserver.int ?
     
  7. kong121s

    kong121s New Member

    Sorry about my english. English language isn't my main language.

    unregister is mean... I didn't register domain for that website.
    (um.. hard to explain for me. please go to http://www.udomain.net/en/main/index.php <<< somewhere to register domain.
    Hope you understand :)
    )
     
  8. falko

    falko Super Moderator

    You must register the domain first before you can use it.

    In order to make Postfix and ISPConfig start at boot time, run this:

    Code:
    chkconfig --levels 235 sendmail off
    chkconfig --levels 235 postfix on
    chkconfig --levels 235 ispconfig_server on
     

Share This Page