ISPConfig Debian 9 (dovecot-sieve dovecot-lmtpd sudo unable to locate)

Discussion in 'Installation/Configuration' started by sijmenNL, Dec 16, 2017.

  1. sijmenNL

    sijmenNL New Member

    Hi

    i followed the how to on https://www.howtoforge.com/tutorial...-9-stretch-apache-bind-dovecot-ispconfig-3-1/

    i am stuck on step 8

    Code:
    [email protected]:~# apt-get install postfix postfix-mysql postfix-doc mariadb-client mariadb-server openssl getmail4 rkhunter binutils dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-sieve dovecot-lmtpd sudo
    
    Reading package lists... Done
    
    Building dependency tree
    
    Reading state information... Done
    
    E: Unable to locate package dovecot-sieve dovecot-lmtpd sudo

    how to fix this

    thanks in advance
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Those packates are available in Debian version 9, codenamed Stretch. Check like this:
    Code:
    [email protected]:~# lsb_release -a
    No LSB modules are available.
    Distributor ID:    Debian
    Description:    Debian GNU/Linux 9.3 (stretch)
    Release:    9.3
    Codename:    stretch
    [email protected]:~# LANG=C apt-cache policy dovecot-sieve
    dovecot-sieve:
      Installed: (none)
      Candidate: 1:2.2.27-3+deb9u1
      Version table:
         1:2.2.27-3+deb9u1 500
            500 http://debian.mirrors.ovh.net/debian stretch/main amd64 Packages
    [email protected]:~#
    
    If those packages are not shown as candidates, try "apt-get update". If still no luck check what is in /etc/apt/sources.list and in directory /etc/apt/sources.list.d/.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The install command is fine and the package exists in Debian 9, just verified that on my Debian 9 server. Check your /etc/apt/sources.list and compare it with the one from the tutorial
     
    Taleman likes this.
  4. sijmenNL

    sijmenNL New Member

    This is mine only i got the dutch mirror of debian

    Code:
    #
    
    # deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official amd64 NETINST 20171209-12:10]/ stretch m$
    
    #deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official amd64 NETINST 20171209-12:10]/ stretch ma$
    
    deb http://ftp.nl.debian.org/debian/ stretch main contrib non-free
    deb-src http://ftp.nl.debian.org/debian/ stretch main contrib non-free
    
    deb http://security.debian.org/debian-security stretch/updates main contrib non-free
    deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free
    
    # stretch-updates, previously known as 'volatile'
    deb http://ftp.nl.debian.org/debian/ stretch-updates main contrib non-free
    deb-src http://ftp.nl.debian.org/debian/ stretch-updates main contrib non-free
    


    but have done a apt-get update again and now it works strange have done it twice already even in new install

    Solved by Taleman and till ;);)
     
    Last edited: Dec 17, 2017

Share This Page