ISPconfig control panel works but websites dont

Discussion in 'Installation/Configuration' started by AnthonyArde, Apr 3, 2008.

  1. AnthonyArde

    AnthonyArde New Member

    Hi all, i have just finished installing ISPConfig and it works! well half works.

    i have created a new client and site. the domain and dns is handled by dyndns as that is where i created the domain.

    once i created it i could only log into the controlpanel section ie: http://domainname:81
    but the actual website doesnt work, ie: http://domainname

    I have bind 9 installed, will this conflict with the workings of the dyndns site? With the DNS etc? i dont know how it can because the control panel works, i have tested it on a different internet connection and it works fine. it seems only the web sites arent working.

    also in the /etc/hosts - do i have to fill in every domain under the ip i am using?

    and my ftp works fine, just not the website.

    Thanks

    Anthony
     
    Last edited: Apr 3, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please craete a website in ispconfig for your domain name. Make sure that you select the internal IP address for the website and that you forward port 80 from your router to your server.
     
  3. AnthonyArde

    AnthonyArde New Member

    .

    the domain that i have is the domain that i`m using for ispconfig server, ie:
    under management and settings i have my domain name as the host and domain. are you asking me to create a site with this same domain name?

    i have another domain that i created with dyndns and i have tried to create a site with this domain, and it didnt work.

    or do i need to create a site with the first domain that is also my isp servers domain?

    all ports required have been forwarded correctly.

    Thanks

    Anthony.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You can use whatever domain you like to create a web site, but make sure that its DNS records are pointing to your server.
    Regarding the IP address that you have to choose for the web site in ISPConfig: it must be one of the IP addresses that you see in the output of
    Code:
    ifconfig
     
  5. AnthonyArde

    AnthonyArde New Member

    Yes i have created a site and given it these details:

    site one's details:
    hostname: www
    domain : life.boldlygoingnowhere.org
    ip : 192.XXX.X.XX (internal ip of my server, ports are forwarded)
    create dns: Not checked
    create dns mx: Not checked


    ispserver details:
    server name: Server 1
    hostname: mysrv.homeip.net
    domain : mysrv.homeip.net
    ip : 192.XXX.X.XX (internal ip of my server, ports are forwarded)


    the domains : mysrv.homeip.net and life.boldlygoingnowhere.org both point to my external IP with ports forwarded to the internal IP mentioned above

    with this config it doesnt work???

    what should i be doing differently,
    thanks for your assistance in this.
    the internal ip i am using is the same ip for eth0 in ifconfig

    thanks

    Anthony
     
    Last edited: Apr 4, 2008
  6. AnthonyArde

    AnthonyArde New Member

    i have to bump this up, i really require assistance with this,

    thanks

    Anthony
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Try hostname: life and domain: boldlygoingnowhere.org
    If this doesn't help: what's in Vhosts_ispconfig.conf, and what's the output of
    Code:
    ifconfig
    ?
     
  8. AnthonyArde

    AnthonyArde New Member

    here is the info you requested

    i tried what you suggested but it didnt work.
    here is my vhosts info: (this is after i made the changes you suggested)

    # ISPConfig vHost Configuration File
    # Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.1.13:80
    <VirtualHost 192.168.1.13:80>
    ServerName localhost
    ServerAdmin [email protected]
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: life.boldlygoingnowhere.org:80
    ######################################
    #
    #
    <VirtualHost 192.168.1.13:80>
    ServerName life.boldlygoingnowhere.org:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web3/web
    ServerAlias life.boldlygoingnowhere.org
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 $
    ErrorLog /var/www/web3/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    Alias /error/ "/var/www/web3/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web3/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web3/user/$1/web/$3
    </VirtualHost>
    #
    #
    #


    here is my ifconfig:

    eth0 Link encap:Ethernet HWaddr 00:11:5B:6E:BB:F7
    inet addr:192.168.1.13 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::211:5bff:fe6e:bbf7/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1781 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1525 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1429579 (1.3 MB) TX bytes:564574 (551.3 KB)
    Interrupt:16 Base address:0xec00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:116 errors:0 dropped:0 overruns:0 frame:0
    TX packets:116 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:22026 (21.5 KB) TX bytes:22026 (21.5 KB)
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Is life.boldlygoingnowhere.org pointing to the correct IP address? Is port 80 open in your firewall? Also make sure that your ISP doesn't block port 80.
     
  10. AnthonyArde

    AnthonyArde New Member

    all is open

    i phoned my isp a few days ago to make sure and they say it is open...? all ports are forwarded correctly to the correct ip.

    i`m thinking it might have something to do with the dns, what should my settings be for my dns?

    do i require to add an entry for life.boldlygoingnowhere.org?

    thanks for your assistance falco.

    if life.boldlygoingnowhere.org and mysrv.homeip.net should be 192.168.1.13 then yes the ip is correct.
     
    Last edited: Apr 7, 2008
  11. falko

    falko Super Moderator ISPConfig Developer

    Code:
    server1:/var/log# dig life.boldlygoingnowhere.org
    
    ; <<>> DiG 9.3.4 <<>> life.boldlygoingnowhere.org
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64277
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;life.boldlygoingnowhere.org.   IN      A
    
    ;; ANSWER SECTION:
    life.boldlygoingnowhere.org. 60 IN      A       [B][COLOR="Red"]196.209.52.23[/COLOR][/B]
    
    ;; Query time: 135 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Mon Apr  7 18:23:38 2008
    ;; MSG SIZE  rcvd: 61
    
    server1:/var/log#
    Is that your router's public IP address?
     

Share This Page