ISPCONFIG control panel shows code instead of displaying it.

Discussion in 'Installation/Configuration' started by Maile Halatuituia, Nov 22, 2016.

  1. its already install
    apt-get install libapache2-mod-fcgid
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libapache2-mod-fcgid is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    What is your /etc/apache2/sites-enabled/000-ispconfig.vhost?
     
  3. this is part of it
    Listen 8080
    #NameVirtualHost *:8080

    <VirtualHost _default_:8080>
    ServerAdmin [email protected]

    <Directory /var/www/ispconfig/>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>
    <Directory /usr/local/ispconfig/interface/web/>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    <FilesMatch "\.php$">
    SetHandler fcgid-script
    </FilesMatch>
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Require all granted
    </Directory>
    IPCCommTimeout 7200
    MaxRequestLen 15728640
    </IfModule>
    you want me to paste all of it ???
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The file looks fine, it's the same on every ispconfig install. Maybe mod_fcgid is not enabled. Did you try:

    a2enmod fcgid
    service apache2 restart
     
  5. After enable fcgid and restart i got all sort of error below

    [Thu Nov 24 10:33:04.574375 2016] [ssl:warn] [pid 5268] AH01906: panel.mic.gov.to:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Nov 24 10:33:04.574666 2016] [ssl:warn] [pid 5268] AH01906: panel.mic.gov.to:8080:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Nov 24 10:33:04.574682 2016] [ssl:error] [pid 5268] AH02217: ssl_stapling_init_cert: Can't retrieve issuer certificate!
    [Thu Nov 24 10:33:04.574684 2016] [ssl:error] [pid 5268] AH02567: Unable to configure certificate panel.mic.gov.to:8080:0 for stapling
    [Thu Nov 24 10:33:04.574745 2016] [suexec:notice] [pid 5268] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Thu Nov 24 10:33:04.595017 2016] [auth_digest:notice] [pid 5270] AH01757: generating secret for digest authentication ...
    [Thu Nov 24 10:33:04.595133 2016] [fcgid:emerg] [pid 5270] (2)No such file or directory: mod_fcgid: Can't create shared memory for size 1200712 bytes
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    http://kb.odin.com/en/121494

    The apths on your server are probably different as the above post is for centos. But if you google for "mod_fcgid: Can't create shared memory for size 1200712 bytes" then you will find several posts explaining the solution.
     
  7. re install fcgid and enable seems to start apache but still warning on the log .. is this normal


    [ssl:warn] [pid 7220] AH01906: panel.mic.gov.to:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Nov 24 11:07:39.304015 2016] [ssl:warn] [pid 7220] AH01906: panel.mic.gov.to:8080:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Nov 24 11:07:39.304139 2016] [ssl:error] [pid 7220] AH02217: ssl_stapling_init_cert: Can't retrieve issuer certificate!
    [Thu Nov 24 11:07:39.304198 2016] [ssl:error] [pid 7220] AH02567: Unable to configure certificate panel.mic.gov.to:8080:0 for stapling
    [Thu Nov 24 11:07:39.304319 2016] [suexec:notice] [pid 7220] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Thu Nov 24 11:07:39.326358 2016] [auth_digest:notice] [pid 7222] AH01757: generating secret for digest authentication ...
    [Thu Nov 24 11:07:39.337413 2016] [:notice] [pid 7226] FastCGI: process manager initialized (pid 7226)
    [Thu Nov 24 11:07:39.359553 2016] [ssl:warn] [pid 7222] AH01906: panel.mic.gov.to:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Nov 24 11:07:39.359977 2016] [ssl:warn] [pid 7222] AH01906: panel.mic.gov.to:8080:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Nov 24 11:07:39.360062 2016] [ssl:error] [pid 7222] AH02217: ssl_stapling_init_cert: Can't retrieve issuer certificate!
    [Thu Nov 24 11:07:39.360190 2016] [ssl:error] [pid 7222] AH02567: Unable to configure certificate panel.mic.gov.to:8080:0 for stapling
    [Thu Nov 24 11:07:39.362196 2016] [mpm_prefork:notice] [pid 7222] AH00163: Apache/2.4.10 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 PHP/5.5.9-1ubuntu4.20 OpenSSL/1.0.1f configured -- resuming normal operations
    [Thu Nov 24 11:07:39.362240 2016] [core:notice] [pid 7222] AH00094: Command line: '/usr/sbin/apache2'
     
  8. Strange , i suspect that is it with the link to my ispconfig interface co's i guess the server display the default index file on ubuntu co's it does not find the correct path to ispconfig interface ... This is because if i use normal http then it is goes to this warning page
    Bad Request
    Your browser sent a request that this server could not understand.
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.
     
  9. my situation now is when i load https://myip:8080 it goes to the ubntu default index file instead of the ispconfig interface .. looks likes apache does not read 000-ispconfig.conf -> ../sites-available/ispconfig.conf and 100-ispconfig.vhost -> ../sites-available/ispconfig.vhost
     
  10. I hope someone would help me fix this issue.
    Thanks in advance
     
  11. Till
    Any comment about my last post below
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's normal.

    Try to reboot the server to ensure that you do not have any hanging apache processes that do not read the new config.

    If you need help by remote login, then please contact Florian from ISPConfig business support: http://www.ispconfig.org/get-support/?type=ispconfig
     
  13. PeterDig

    PeterDig New Member

    I have the same message.
    And I found the reason, but I don't know how to fix it.
    refer link(sorry i cannot send link, the page is on serverfault and questions number is 576939)
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    The serverfault message 576939 is not related to this problem. Namevirtualhost warnings are completely harmless and no indication of a problem.
     

Share This Page