ISPCONFIG control panel shows code instead of displaying it.

Discussion in 'Installation/Configuration' started by Maile Halatuituia, Nov 22, 2016.

  1. My host sites are all OK except the ispconfig site not display instead the php code is shown on the browser.
    This happen after i try to install OMD Check_MK on the same server. What i saw in the process that all app uninstalled, after OMD install every thing break. So i decide to uninstall it and move it to a separate server but i am still trying to restore everything except the ispconfig control panel itself not display.
    I hope this make sense and hopefully someone would give a hint.

    Thanks in advance.
    Maile
     
  2. After fiddling around i get this error this time ...

    AH00526: Syntax error on line 25 of /etc/apache2/sites-enabled/000-ispconfig.vhost:
    FCGIWrapper takes one, two or three arguments, Deprecated - Use 'FcgidWrapper' instead
    Action 'configtest' failed.
    The Apache error log may have more information.

    i hope someone would give a hint ...
    thanks in advance
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that all apache modules are installed and enabled as described in the apache installation part of the perfect server guide. then run an ispconfig update with reconfigure services.
     
  4. Hi Till
    Thanks for your reply ...
    I run in to several error after trying to reinstall apache2 and php5, however i return to the perfect server install and manage to reinstall both apache and php5 with modules and all my site are OK now except my ispconfig interface on my control panel.
    Here is the error on the apache2 log and it only happen when i view my ispconfig interface, the reset of my site are all ok... error below
    [authz_core:error] [pid 6192] [client 172.30.0.2:13102] AH01630: client denied by server configuration: /var/www/........
     
  5. After run ispconfig update then i get this error
    SSLStapling: no stapling cache availablev and apache cannot start
     
  6. i am lost now after is uninstall ispconfig then install it again i got this when trying start apache ...

    SSLStapling: no stapling cache available[Wed Nov 23 12:19:32.549273 2016] [ssl:emerg] [pid 12957] AH01958: SSLStapling: no stapling cache available
    [Wed Nov 23 12:19:32.549446 2016] [ssl:emerg] [pid 12957] AH02312: Fatal error initialising mod_ssl, exiting.
    [Wed Nov 23 12:19:50.856573 2016] [ssl:emerg] [pid 13019] AH01958: SSLStapling: no stapling cache available
    [Wed Nov 23 12:19:50.856777 2016] [ssl:emerg] [pid 13019] AH02312: Fatal error initialising mod_ssl, exiting.

    i am just waiting for a hint otherwise i will rebuild everything from scratch now ... hopeless ...
     
  7. the reason i am hopeless is that all thing were ok till i try to fix the issue with my isoconfig interface by reinstalling ispconfig then i got this error .. can someone help ... appreciate ...
     
  8. Jesse Norell

    Jesse Norell Active Member

    The cache is defined in the ispconfig vhost, what do you get for
    Code:
    grep -R SSLStapling /etc/apache2/
     
  9. Thanks Jesse
    grep -R SSLStapling /etc/apache2/
    /etc/apache2/sites-available/ispconfig.vhost: SSLStaplingResponderTimeout 5
    /etc/apache2/sites-available/ispconfig.vhost: SSLStaplingReturnResponderErrors Off
    /etc/apache2/sites-available/ispconfig.vhost: SSLStaplingCache shmcb:/var/run/ocsp(128000)
    here is the output
     
  10. Now specifically i have this issue.

    1. If i enable ispconfig.vhost it gives this error when restart apache and cannot start.
    Address already in use: AH00072: make_sock: could not bind to address [::]:8080

    2. If i also enable apps.vhost it gives the same complain
    Address already in use: AH00072: make_sock: could not bind to address [::]:8081
    Removing both this symlink on my sites-enabled make apache start again and all my website a fine except the ispconfig interface .....
     
  11. also no apparmor or nothing is run in these ports ...
     
  12. also it is a vistual machine running on Oracle VirtualBox
     
  13. now manage to find that i have duplicate the sites enabled. Removed one and able to start apache with ispconfig enable however i have another issue.
    When i access my https://ip:8080 it shows the normal ubuntu home page in /var/www/html instead of showing ispconfig interface ... any hint would be very much appreciate ....
    thanks in advance.
    Maile
     
  14. Jesse Norell

    Jesse Norell Active Member

    run the ispconfig updater and let it reconfigure services.
     
  15. s
    till the same ... should i reinstall ???
     
  16. Jesse Norell

    Jesse Norell Active Member

    You do have the ispconfig vhost enabled now? (you did not in the above grep command, but the reconfigure should have fixed that) What does 'apachectl -S' show?
     
  17. yes ispconfig vhost enabled
    output of command above
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:69
    VirtualHost configuration:
    *:8081 panel.mic.gov.to (/etc/apache2/sites-enabled/000-apps.vhost:9)
    *:8080 panel.mic.gov.to (/etc/apache2/sites-enabled/000-ispconfig.vhost:9)
    *:80 is a NameVirtualHost
    default server panel.mic.gov.to (/etc/apache2/sites-enabled/000-default.conf:1)
    port 80 namevhost panel.mic.gov.to (/etc/apache2/sites-enabled/000-default.conf:1)
    port 80 namevhost hrms.mic.gov.to (/etc/apache2/sites-enabled/100-hrms.mic.gov.vhost:6)
    port 80 namevhost intranet.mic.gov.to (/etc/apache2/sites-enabled/100-intranet.mic.gov.vhost:6)
    port 80 namevhost monitor.mic.gov.to (/etc/apache2/sites-enabled/100-monitor.mic.gov.vhost:6)
    port 80 namevhost squidanalyzer.mic.gov.to (/etc/apache2/sites-enabled/100-squidanalyzer.mic.gov.vhost:6)
    port 80 namevhost webmail.mic.gov.to (/etc/apache2/sites-enabled/100-webmail.mic.gov.vhost:6)
    alias mail.mic.gov.to
    alias webmail.cpr.gov.to
    ServerRoot: "/etc/apache2"
    Main DocumentRoot: "/var/www/html"
    Main ErrorLog: "/var/log/apache2/error.log"
    Mutex rewrite-map: using_defaults
    Mutex authdigest-client: using_defaults
    Mutex ssl-stapling: using_defaults
    Mutex ssl-cache: using_defaults
    Mutex default: dir="/var/lock/apache2" mechanism=fcntl
    Mutex mpm-accept: using_defaults
    Mutex authdigest-opaque: using_defaults
    Mutex watchdog-callback: using_defaults
    PidFile: "/var/run/apache2/apache2.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    Define: ENABLE_USR_LIB_CGI_BIN
    User: name="www-data" id=33
    Group: name="www-data" id=33
     
  18. Jesse Norell

    Jesse Norell Active Member

    That looks right. Do you have mod_fcgid installed/enabled?
     
  19. not sure ...how can i properly check it ... otherwise i install wrong packages ...
    i am useing

    NAME="Ubuntu"
    VERSION="14.04.5 LTS, Trusty Tahr"
    ID=ubuntu
    ID_LIKE=debian
    PRETTY_NAME="Ubuntu 14.04.5 LTS"
    VERSION_ID="14.04"
     
  20. Jesse Norell

    Jesse Norell Active Member

    Try 'apt-get install libapache2-mod-fcgid' (that's the debian package name .. guessing ubuntu is the same).
     

Share This Page