ISPConfig config changes 10.04 to 14.04

Discussion in 'Installation/Configuration' started by olimortimer, Dec 30, 2014.

  1. olimortimer

    olimortimer Member


    I currently run a Ubuntu 10.04 server with ISPConfig installed.

    I'm looking at upgrading Ubuntu from 10.04 to 14.04 (I understand this needs to be done in steps; 10.04 > 12.04 > 14.04), and wondered if there was a guide to ensure ISPConfig works OK after the upgrade? Ie, any additional changes that need to be made to config files etc.

    FYI if I run the ISPConfig common issues check, I believe everything is working ok;

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [INFO] ISPConfig is installed.
    ##### ISPCONFIG #####
    ISPConfig version is
    ##### VERSION CHECK #####
    [INFO] php (cli) version is 5.3.2-1ubuntu4.28
    ##### PORT CHECK #####
    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening
    ##### MAIL SERVER CHECK #####
    [WARN] I found no "submission" entry in your postfix
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.
    [INFO] I found the following web server(s):
            Apache 2 (PID 4221)
    [INFO] I found the following mail server(s):
            Postfix (PID 2127)
    [INFO] I found the following pop3 server(s):
            Courier Mailserver (PID 1978)
    [INFO] I found the following imap server(s):
            Courier Mailserver (PID 1944)
    [INFO] I found the following ftp server(s):
            PureFTP (PID 2142)
    ##### LISTENING PORTS #####
    (only           ()
    Local           (Address)
    [localhost]:10024               (986/amavisd)
    [localhost]:10025               (2127/master)
    [anywhere]:3306         (888/mysqld)
    [localhost]:11211               (2004/memcached)
    [anywhere]:80           (4221/apache2)
    [anywhere]:8081         (4221/apache2)
    [anywhere]:21           (2142/pure-ftpd)
    ***.***.***.***:53              (884/named)
    [localhost]:53          (884/named)
    [anywhere]:22           (721/sshd)
    [anywhere]:25           (2127/master)
    [localhost]:953         (884/named)
    [anywhere]:8443         (4221/apache2)
    [anywhere]:443          (4221/apache2)
    *:*:*:*::*:993          (1964/couriertcpd)
    *:*:*:*::*:995          (1998/couriertcpd)
    [localhost]10           (1978/couriertcpd)
    [localhost]43           (1944/couriertcpd)
    *:*:*:*::*:21           (2142/pure-ftpd)
    *:*:*:*::*:53           (884/named)
    *:*:*:*::*:22           (721/sshd)
    *:*:*:*::*:953          (884/named)
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the main problem will be the switch from apache 2.2 to apache 2.4 as apache 2.4 uses a different syntax. In any case, make a backup before you start :)

    Then I would disable the websites before the update by removing the symlinks in /etc/apache2/sites-enabled/ for all sites but not the default website and the ispconfig vhost and the ispconfig conf file. Then do the os updates until 14.04, then run a ispconfig update like this:

    cd /tmp
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    and let it reconfigure services, Then login into, go to the tools module and run a resync on the websites with the resync tool. This will recreate the symlinks that we deleted at the start and itwill change the config syntax for the vhosts to the 2.4 syntax.
  3. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Why won´t you delete the default-vhost?
    On wheezy you have a default-vhost thats allows you access to /var/www if the name does not exists (and you have a wildcard-record in the dns) and this vhost listens to all ip-adresses.
    I disable this vhost and don´t know why it should be used?
  4. olimortimer

    olimortimer Member

    Ok, so it kind of went ok...

    However after the upgrade, re-running the ISPConfig install, and re-syncing the sites, the PHP-FPM sites weren't working (I can't 100% remember what errors were being shown now).

    I then ran steps 14 from here;

    ..but was still having problems. So I added the config from step 5 on here;

    I then had to disable PHP for each site, and re-enable it as a PHP-FPM site through ISPConfig, due to the following showing in the error logs;
  5. olimortimer

    olimortimer Member

    Ok, so I rebooted the server after sorting everything out...and it never came back up again. My host thinks it had a 'kernel panic'.

    I could use my backup to go back to 10.04 LTS, but thinking I should just bite the bullet and take this as an opportunity to upgrade Ubuntu cleanly. So, we're currently rebuilding the server to a blank 12.04 LTS install (14.04 LTS not available as a VPS image with my host), and then will have to reinstall ISPConfig, and re-add all my sites / email accounts / DNS etc.

    Next question...Apache or Nginx?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ngnx is nice and fast, but it does not read the .htaccess files in the websites which are apache only. So you would have to convert all .htaccess files for the websites into nginx syntax and then add these lines into the nginx directives field of the website in ISPConfig. If you stay with apache, it will be easier for you.
    olimortimer likes this.

Share This Page