ispconfig.conf file in wrong place

Discussion in 'Developers' Forum' started by theamoeba, Feb 26, 2009.

  1. theamoeba

    theamoeba ISPConfig Developer ISPConfig Developer

    hi, think i found a bug in the fedora version of ispconfig 3.

    bug is that the ispconfig.conf in /etc/httpd/conf/sites-available is not being read by apache and therefore the NameVirtualHost is not being read. This causes apache to only read one domain.tld.vhost and disregard the others.

    what i did was move the ispconfig.conf into /etc/httpd/conf.d and it seems to work fine now, i suppose this is not a great thing to do, you could also edit the httpd.conf file and include the file i dont know.

    perhaps someone could look into this and change it?

    thanks, J
     
  2. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker. Fedora and CentOS support is still experimental.
     
  3. reason8

    reason8 New Member

    How about OpenSuse 11.1? I am having the same problem and getting the same error but not on install. Only on restararting apache2 but the result is the same.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The conf file is in the correct place and the folder is read by apache. Take a look at your apache2.conf file or httpd.conf file, you will find the include statements there.
     
  5. reason8

    reason8 New Member

    Ok. Someone gave me the solution to my problem. I needed to add the server IP manually to the server IP config. There is no way I would have guessed this. I figured the server KNEW it was using the static ip from the install. *shrugs*.

    Thanks for your help. I the new ISPConfig 3 rocks. It seems way more robust than its predecesor, the look and feel are far superior and its the new version so I am happy! :)
     
  6. jcasoft

    jcasoft New Member

    Other solutions to this problem

    In the /etc/apachae2/sites-available (For OpenSuse)
    the file of your domain: yourdomain.com.vhost

    <VirtualHost *:80>


    DocumentRoot /srv/www/yourdomain/web



    ServerName www.yourdomain.com # your complete FQDN
    ServerAdmin [email protected]
    .....
    .....

    If you create a New site in ISPCONFIG3 in the field
    Domain: www.yourdomain.com # your complete FQDN

    If you enter only Domain: yourdomain.com
    the /etc/apachae2/sites-available (For OpenSuse)
    the file of your domain: yourdomain.com.vhost

    the line ServerName yourdomain.com # you need to add manualy the www
    like: ServerName www.yourdomain.com


    This work fine for me.:)
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    No need for editing anything manually. You just missed to enable the auto subdomain www in the site settings.
     

Share This Page