ISPConfig: click database icon results in PHP version required message

Discussion in 'Installation/Configuration' started by 30uke, May 24, 2021.

  1. 30uke

    30uke Member HowtoForge Supporter

    Hello,
    When I do navigate to "Sites" > "Databases" and click the database icon next to a database name, this results in the following error:
    Code:
    PHP 7.1.3+ is required.
    Currently installed version is: 7.0.33-0+deb9u3
    When I execute the php --version command, PHP will show version 7.3.27-1~deb10u1.
    Code:
    # php --version
    PHP 7.3.27-1~deb10u1 (cli) (built: Feb 13 2021 16:31:40) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.27, Copyright (c) 1998-2018 Zend Technologies
        with Zend OPcache v7.3.27-1~deb10u1, Copyright (c) 1999-2018, by Zend Technologies
    When I try this on my other ISPConfig server, then PHPMyAdmin will open.
    When I look at the file "php" under "/var/lib/dpkg/alternatives" then this reveals version 7.0 and 7.3.
    Code:
    [email protected]:/var/lib/dpkg/alternatives# cat php
    auto
    /usr/bin/php
    php.1.gz
    /usr/share/man/man1/php.1.gz
    
    /usr/bin/php7.0
    70
    /usr/share/man/man1/php7.0.1.gz
    /usr/bin/php7.3
    73
    /usr/share/man/man1/php7.3.1.gz
    I am running ISPConfig 3.2.4 on Debian 10.9.
    Is there something I need to change? I can run phpmyadmin without problems (when executed directly from the address bar).
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Ensure all versions of mod_php are uninstalled, and you a2enconf php7.3-fpm, then restart apache and see what you have. You might also check the default php version for the server in PHP Settings.
     

Share This Page