ISPConfig ClamAV 0.93 Update

Discussion in 'General' started by till, Apr 15, 2008.

Thread Status:
Not open for further replies.
  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Several vulnerabilities had been discovered in ClamAV 0.92.1. Please update ClamAV 0.92.1 (which comes with ISPConfig 2.2.22) to ClamAV 0.93 with the following patch.

    Installation instructions
    -----------------------------------------------------------------------

    Login to your server as root user on the shell. Then execure the following commands:

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ispconfig_clamav-0.93.tar.gz
    tar xvfz ispconfig_clamav-0.93.tar.gz
    cd compile_clamav
    ./compile
    
    ISPConfig 2.2.23 will be released soon which conatins the new ClamAV version too. If you installed this patch, it is not nescessary to update to ISPConfig 2.2.23.
     
    Last edited: Apr 15, 2008
  2. daveb

    daveb Member

    Hey Till I installed this last night given the instructions falko posted some time ago.
    Code:
    ./configure --prefix=/home/admispconfig/ispconfig/tools/clamav --sysconfdir=/home/admispconfig/ispconfig/tools/clamav/etc --with-user=admispconfig --with-group=admispconfig --disable-clamav --disable-bzip2 --disable-zlib-vcheck
    It worked but after configure I got this warning
    Code:
    configure: WARNING:
    ****** WARNING:
    ****** You are either cross compiling to a different host or
    ****** you have manually disabled important configure checks.
    ****** Please be aware that this build may be badly broken.
    ****** DO NOT REPORT BUGS BASED ON THIS BUILD !!!
    is this anything to worrie about?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats nothing to worry about. But you should use the update I posted above and update your sytsem again as my update contains some changed config files too.
     
  4. Snowman

    Snowman Member

    Hi, i recommend to delete after compiling(not necessary but everybody want to have clean system)
    host:/tmp# cd ..
    host:/tmp# rm -r compile_clamav/
    host:/tmp# rm -r ispconfig_clamav-0.93.tar.gz

    :)
     
  5. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If your updater has not modified the syntax of the clamav.conf file and freshclam.conf file, you should update these config files with the versions that I included in the tar.gz package above. Several configuration directives are not supported anymore and clamav will throw errors when you run it with the old config files.
     
  7. daff

    daff New Member

    Hello,

    some time ago I followed that tutorial because I had a problem with quota:
    http://www.howtoforge.com/forums/showthread.php?t=16204
    should I update to ClamAV 0.93 ? I ask that question because I use now clamd. Is the bug with the quota (big/much files in /tmp) fixed in 0.93 ? If I should return to the "normal" clamav how should i act?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Install the patch that I posted above and the run:

    /etc/init.d/clamav-daemon restart

    The issues with the temp files had not been fixed yet as far as I know.
     
  9. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    Mandriva 2007.1 patch work ok.
    clamassassin 1.2.4 with clamscan / ClamAV 0.93/6850/
     
  10. andron26

    andron26 Member

    problem with update

    Hi,

    OpenSuSe 10.2.
    When I want to update clamav I have such error:

    /tmp/compile_clamav/clamav-0.93/freshclam/../shared/cdiff.c:984: undefined reference to `gzdopen'
    /tmp/compile_clamav/clamav-0.93/freshclam/../shared/cdiff.c:994: undefined reference to `gzgets'
    /tmp/compile_clamav/clamav-0.93/freshclam/../shared/cdiff.c:1016: undefined reference to `gzclose'
    /tmp/compile_clamav/clamav-0.93/freshclam/../shared/cdiff.c:1010: undefined reference to `gzclose'
    tar.o: In function `tar_addfile':
    /tmp/compile_clamav/clamav-0.93/freshclam/../shared/tar.c:82: undefined reference to `gzwrite'
    /tmp/compile_clamav/clamav-0.93/freshclam/../shared/tar.c:95: undefined reference to `gzwrite'
    /tmp/compile_clamav/clamav-0.93/freshclam/../shared/tar.c:111: undefined reference to `gzwrite'
    manager.o: In function `buildcld':
    /tmp/compile_clamav/clamav-0.93/freshclam/manager.c:932: undefined reference to `gzclose'
    /tmp/compile_clamav/clamav-0.93/freshclam/manager.c:944: undefined reference to `gzclose'
    /tmp/compile_clamav/clamav-0.93/freshclam/manager.c:884: undefined reference to `gzopen'
    /tmp/compile_clamav/clamav-0.93/freshclam/manager.c:913: undefined reference to `gzclose'
    collect2: ld returned 1 exit status
    make[2]: *** [freshclam] Error 1
    make[2]: Leaving directory `/tmp/compile_clamav/clamav-0.93/freshclam'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/tmp/compile_clamav/clamav-0.93'
    make: *** [all] Error 2
    ERROR: Could not make ClamAV
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Is AppArmor disabled on your system?
     
  12. rbartz

    rbartz Member

    I am getting same error on Fedora Core 3

    Same problem with the patch...

    I tried the patch because both 2.2.22 and 2.2.23 both failed to install due to errors. I remade /root/ispconfig directory and reverted back to 2.2.21 and it re-installed perfectly, so things are fine but for the older version of ClamAV.

    Since the makes failed, I assume I do not need to "undo" the patch, right?

    Thanks for all your hard work.

    Richard
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's right.
     
  14. t-mug

    t-mug New Member

    Clamav 93.1

    Do you think, the compile scripts included in the package of the start post work as well with a replaced clamav 93.1 package?
     
  15. Ben

    Ben ISPConfig Developer ISPConfig Developer

  16. t-mug

    t-mug New Member

    Thx

    I had not seen that post yet, thanks.
     
  17. Ben

    Ben ISPConfig Developer ISPConfig Developer

    No problem. Just updated and it works fine. Just replaced the new clamav archive with the old and changed the version in the "compile" script.
     
  18. mtnsnyder

    mtnsnyder New Member

    I'd like to update my clamav from 0.93 to 0.94.2 (current). All help I have found regarding how to do this references an ispconfig specific version of the clamav package:

    http://www.ispconfig.org/downloads/ispconfig_clamav-0.93.tar.gz

    I went looking for http://www.ispconfig.org/downloads/ispconfig_clamav-0.94.2.tar.gz

    but this does not appear to exist. Getting the "standard" version from clamav's site here: http://sourceforge.net/project/showfiles.php?group_id=86638 is of no help because it fails on the .configure script since no clamav user or group exists.

    Would someone please instuct me on how to upgrade this, or point me to some instructions on how to do so. I don't want to end up creating more work for myself as a result of a screwup on my behalf while trying to perform (what should be) a simple upgade...

    Any assistance will be appreciated.
     
  19. Ben

    Ben ISPConfig Developer ISPConfig Developer

    I put a update package to 0.94.1 here, when this release came up.
    Just download this, extract, remove the clamav 0.94.1 package within, replace with the one you can download from the clamav wegpage, change the version numer in the compile file to 0.94.2 and run compile. Worked well for me ;)

    That's the thread where the link for the 0.94.1 is placed: http://www.howtoforge.com/forums/showthread.php?t=28595&highlight=0.94.1
     
  20. mtnsnyder

    mtnsnyder New Member

    Fantastic! I did just that and it worked perfectly :) Thanks very much for the advice. Now running 0.94.2, thank you.
     
Thread Status:
Not open for further replies.

Share This Page